Bug 1252072 - POSIX ACLs as used by a FUSE mount can not use more than 32 groups
POSIX ACLs as used by a FUSE mount can not use more than 32 groups
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
3.6.3
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Niels de Vos
: Triaged
Depends On: 1246275 1275721
Blocks: glusterfs-3.6.6
  Show dependency treegraph
 
Reported: 2015-08-10 12:10 EDT by Niels de Vos
Modified: 2015-10-27 10:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.6.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1246275
Environment:
Last Closed: 2015-09-30 08:15:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2015-08-10 12:10:06 EDT
+++ This bug was initially created as a clone of Bug #1246275 +++

Description of problem:
When enabling support for POSIX ACLs on a FUSE mount with the "-o acl" mount option, permission checks only use the first 32 groups of a user. If permissions of a directory/file are permitted by groups further in the group-list, the permissions are not applied. The group-list of the user is truncated to the fist 32 groups.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
100%

Steps to Reproduce:
1. mount a volume with "-o acl"
2. create a lot of groups (33 or more)
3. create a user that belongs to a lot of groups
4. create a directory on the volume
5. add a POSIX ACL to the new directory, allow writes for the directory to the 
   last group the user belongs to (setfacl -m g:123456:rwx /path/new/dir)
6. create a new file in the director as the user

Actual results:
"Permission denied"

Expected results:
The user should be allowed to create the file, the user is member of the group with write access.

Additional info:
If the number of groups the user belongs to is higher than ~93, the volume option server.manage-gids needs to be enabled too.

--- Additional comment from Anand Avati on 2015-07-24 00:14:49 CEST ---

REVIEW: http://review.gluster.org/11732 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-07-29 16:36:59 CEST ---

REVIEW: http://review.gluster.org/11732 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-08-05 13:53:26 CEST ---

COMMIT: http://review.gluster.org/11732 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 64a5bf3749c67fcc00773a2716d0c7b61b0b4417
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Jul 21 18:50:12 2015 +0200

    fuse: add "resolve-gids" mount option to overcome 32-groups limit
    
    Add a --resolve-gids commandline option to the glusterfs binary. This
    option gets set when executing "mount -t glusterfs -o resolve-gids ...".
    
    This option is most useful in combination with the "acl" mount option.
    POSIX ACL permission checking is done on the FUSE-client side to improve
    performance (in addition to the checking on the bricks).
    
    The fuse-bridge reads /proc/$PID/status by default, and this file
    contains maximum 32 groups. Any local (client-side) permission checking
    that requires more than the first 32 groups will fail.
    
    By enabling the "resolve-gids" option, the fuse-bridge will call
    getgrouplist() to retrieve all the groups from the user accessing the
    mountpoint. This is comparable to how "nfs.server-aux-gids" works.
    
    Note that when a user belongs to more than ~93 groups, the volume option
    server.manage-gids needs to be enabled too. Without this option, the
    RPC-layer will need to reduce the number of groups to make them fit in
    the RPC-header.
    
    Change-Id: I7ede90d0e41bcf55755cced5747fa0fb1699edb2
    BUG: 1246275
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/11732
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 1 Anand Avati 2015-08-10 12:24:38 EDT
REVIEW: http://review.gluster.org/11876 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#1) for review on release-3.6 by Niels de Vos (ndevos@redhat.com)
Comment 2 Anand Avati 2015-08-14 04:57:07 EDT
REVIEW: http://review.gluster.org/11876 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#2) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 3 Anand Avati 2015-08-19 03:28:51 EDT
REVIEW: http://review.gluster.org/11876 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#3) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 4 Anand Avati 2015-08-21 02:40:14 EDT
REVIEW: http://review.gluster.org/11876 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#4) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 5 Vijay Bellur 2015-09-10 08:39:11 EDT
REVIEW: http://review.gluster.org/11876 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#5) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 6 Vijay Bellur 2015-09-10 09:14:01 EDT
REVIEW: http://review.gluster.org/11876 (fuse: add "resolve-gids" mount option to overcome 32-groups limit) posted (#6) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 7 Raghavendra Bhat 2015-09-21 02:48:55 EDT
http://review.gluster.org/#/c/11876/ has been merged.
Comment 8 Raghavendra Bhat 2015-09-30 08:15:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.6, please open a new bug report.

glusterfs-3.6.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-devel/2015-September/046821.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.