Bug 1252073 - ovirt-engine-cli isn't automatically updated when ovirt-engine is updated
ovirt-engine-cli isn't automatically updated when ovirt-engine is updated
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-cli
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-rc
: 3.6.0.1
Assigned To: Juan Hernández
Ondra Machacek
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 12:13 EDT by jniederm
Modified: 2015-11-27 02:56 EST (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:56:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44945 master MERGED packaging: Require version 3.6 of the CLI Never
oVirt gerrit 45025 ovirt-engine-3.6 MERGED packaging: Require version 3.6 of the CLI Never

  None (edit)
Description jniederm 2015-08-10 12:13:04 EDT
Description of problem:
ovirt-shell can't connect to console on Fedora 22 because 'spice-client' doesn't seem to be available any more and 'remote-viewer' support doesn't work.

Version-Release number of selected component (if applicable):
[oVirt shell (connected)]# info

backend version: 3.6
sdk version    : 3.6.*c.16
cli version    : 3.5.0.6
python version : 2.7.10.final.0

entry point    : https://localhost.localdomain/ovirt-engine/api

installed from http://resources.ovirt.org/pub/yum-repo/ovirt-release36.rpm

How reproducible:
100%

Steps to Reproduce:
1. Create running vm with spice console
2. Run ovirt shell: ovirt-shell -A ca.crt -l https://localhost.localdomain/ovirt-engine/api -u admin@internal
3. Enter command 'console <vm name>'

Actual results:
  =================================================== UNKNOWN ERROR =================================================
                                spice viewer was not found, please install spice first.
  ===================================================================================================================


Expected results:
remove-viewer is executed

Additional info:
according to cli version (3.5.0.6) and that
$ grep remote-viewer /usr/lib/python2.7/site-packages/ovirtcli/platform/posix/spice.py
output nothing despite of https://gerrit.ovirt.org/#/c/29964/3/src/ovirtcli/platform/posix/spice.py it is probably packaging issue.
Comment 1 Allon Mureinik 2015-08-11 03:54:52 EDT
Flagging as infra for initial research, feel free to move it if it's wrongly assigned.
Comment 2 Juan Hernández 2015-08-17 11:03:26 EDT
According to the description of the bug you used version 3.5.0.6:

  cli version: 3.5.0.6

The capability to use the "remote-viewer" was added in 3.6. Please repeat your test with version 3.6.0.0-0.4 or newer. This version is available in the 3.6 repository. For example, for EL7:

  http://resources.ovirt.org/pub/ovirt-3.6-pre/rpm/el7/noarch/ovirt-engine-cli-3.6.0.0-0.4.20150721.gitd43af33.el7.centos.noarch.rpm

If you already had the CLI installed it won't be automatically updated when the engine is updated, because the engine .spec doesn't require a newer version. We may change that, although it is kind of an abuse of the dependencies mechanism:

  packaging: Require version 3.6 of the CLI
  https://gerrit.ovirt.org/44945

You can instead just update the CLI explicitly:

  # yum update ovirt-engine-cli
Comment 3 Ondra Machacek 2015-11-13 06:05:52 EST
$ rpm -qR rhevm | grep rhevm-cli
rhevm-cli >= 3.6.0.0

While upgrade:
13:03:50 [ INFO  ] Yum Download/Verify: rhevm-cli-3.6.0.0-1.el6ev.noarch
Comment 4 Sandro Bonazzola 2015-11-27 02:56:18 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.