Bug 1252121 - tier.t contains pattern matching error in check_counters function
tier.t contains pattern matching error in check_counters function
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pan Ousley
bugs@gluster.org
: Reopened
Depends On:
Blocks: 1260923 1266922
  Show dependency treegraph
 
Reported: 2015-08-10 14:38 EDT by Pan Ousley
Modified: 2016-06-16 09:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1266922 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:30:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pan Ousley 2015-08-10 14:38:24 EDT
Minor error in check_counters() which made the function only work correctly if counters were single digit.
Comment 1 Anand Avati 2015-08-10 14:49:32 EDT
REVIEW: http://review.gluster.org/11877 (cluster/tier: fixed pattern matching error in tier.t) posted (#1) for review on master by Pamela Ousley (pousley@redhat.com)
Comment 2 Nagaprasad Sathyanarayana 2015-10-25 10:59:39 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 3 Niels de Vos 2016-06-16 09:30:14 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.