Bug 1252156 - ERROR writing to file /sys/devices/system/cpu/intel_pstate/no_turbo: Operation not permitted
Summary: ERROR writing to file /sys/devices/system/cpu/intel_pstate/no_turbo: Operatio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Tereza Cerna
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-10 20:27 UTC by Jeff Nelson
Modified: 2016-11-04 07:24 UTC (History)
3 users (show)

Fixed In Version: tuned-2.7.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:24:10 UTC


Attachments (Terms of Use)
tuned logfile (58.12 KB, text/plain)
2015-08-10 20:27 UTC, Jeff Nelson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2479 normal SHIPPED_LIVE tuned bug fix and enhancement update 2016-11-03 14:08:42 UTC

Description Jeff Nelson 2015-08-10 20:27:51 UTC
Created attachment 1061237 [details]
tuned logfile

Description of problem:
The following error appears in /var/log/tuned/tuned.log:

2015-08-10 15:04:11,997 ERROR    tuned.utils.commands: Writing to file /sys/devices/system/cpu/intel_pstate/no_turbo error: [Errno 1] Operation not permitted


Version-Release number of selected component (if applicable):
# yum list installed | egrep tuned
tuned.noarch                          2.5.1-1.el7             @beaker-Server/7.2
tuned-profiles-nfv.noarch             2.5.1-1.el7             @/tuned-profiles-nfv-2.5.1-1.el7.noarch
tuned-profiles-realtime.noarch        2.5.1-1.el7             @beaker-Server-RT 


How reproducible:
Unknown, but it has appeared multiple times

Steps to Reproduce:
1. Install tuned-profiles-realtime # this might be enough
2. tuned-adm profile virtual-host

Actual results:
ERROR in logfile

Expected results:
No errors.

Additional info:
# uname -a
Linux localhost.localdomain 3.10.0-302.rt56.174.el7.x86_64 #1 SMP PREEMPT RT Mon Aug 3 15:01:33 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux
# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.10.0-302.rt56.174.el7.x86_64 root=/dev/mapper/rhel_virtlab420-root ro crashkernel=auto rd.lvm.lv=rhel_virtlab420/root rd.lvm.lv=rhel_virtlab420/swap console=ttyS1,115200 default_hugepagesz=1G isolcpus=1,3,5,7,9,11,13,14,15 nohz_full=1,3,5,7,9,11,13,14,15 intel_pstate=disable nosoftlockup
# lscpu | grep NUMA
NUMA node(s):          2
NUMA node0 CPU(s):     0,2,4,6,8,10,12,14
NUMA node1 CPU(s):     1,3,5,7,9,11,13,15

Comment 3 Jaroslav Škarvada 2015-08-20 16:29:26 UTC
There is intel_pstate check in tuned, thus it shouldn't touch no_turbo if intel_pstate driver isn't loaded. It checks presence of '/sys/devices/system/cpu/intel_pstate' directory. I verified that the directory isn't there if machine is booted with 'intel_pstate=disable', thus Tuned shouldn't touch no_turbo in this case. So it seems intel_pstate driver is active on the machine and the machine hasn't turbo/no_turbo.

Nevertheless, if no_turbo isn't specified in the profile and there is intel_pstate driver, Tuned needn't to save no_turbo state. This could be improved.

Comment 4 Jaroslav Škarvada 2015-08-21 12:43:31 UTC
(In reply to Jaroslav Škarvada from comment #3)
> Nevertheless, if no_turbo isn't specified in the profile and there is
> intel_pstate driver, Tuned needn't to save no_turbo state. This could be
> improved.

Fixed by upstream commit:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=d7cdf56108a235416add0794babb6e72e273b524

Comment 8 errata-xmlrpc 2016-11-04 07:24:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html


Note You need to log in before you can comment on or make changes to this bug.