Bug 125216 - Missing BuildRequires to autoconf/-make at gettext
Summary: Missing BuildRequires to autoconf/-make at gettext
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gettext   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-03 17:26 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 0.14.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 01:12:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-06-03 17:26:37 UTC
Description of problem:
Well, automake and autoconf should be added to the BuildRequires
of gettext as now a patch is applied which causes the need (try
to rebuild gettext without automake/autoconf).

Version-Release number of selected component (if applicable):
gettext-0.14.1-3

Actual results:
--- snipp ---
--- gettext.spec        2004-06-02 08:53:20.000000000 +0200
+++ gettext.spec.rsc    2004-06-03 18:46:38.000000000 +0200
@@ -12,6 +12,9 @@
 Source2: msghack.py
 Patch0: gettext-0.14.1-amd64-libtool.patch
 Prereq: /sbin/install-info
+%ifarch x86_64
+BuildRequires: automake >= 1.8, autoconf >= 2.58
+%endif
 Buildroot: %{_tmppath}/%{name}-%{version}-root

 %description
@@ -43,7 +46,9 @@
 %prep
 rm -rf %{buildroot}
 %setup -q
+%ifarch x86_64
 %patch0 -p1 -b .x86_64
+%endif

 %build
 [ -f  /usr/share/automake/depcomp ] && cp -f /usr/share/automake/{depcomp,ylwrap} . || :
--- snapp ---

Expected results:
Something like my solution or without the conditional things...

Additional info:
I think, the conditional is better, because the patch applying is 
only at AMD64 really needed.

Comment 1 Leon Ho 2004-06-04 01:12:33 UTC
Thanks for your report! It should be fixed on 0.14.1-4.


Note You need to log in before you can comment on or make changes to this bug.