Bug 1252168 - upgrade to docker-1.7.1-7.gitd5a81b3.fc22.x86_64 changes default 'docker create' behavior
Summary: upgrade to docker-1.7.1-7.gitd5a81b3.fc22.x86_64 changes default 'docker crea...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: docker
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-10 21:11 UTC by Adam Miller
Modified: 2015-11-28 02:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-28 02:48:13 UTC
Type: Bug


Attachments (Terms of Use)
A diff between a version of docker that worked and latest (16.76 KB, text/plain)
2015-08-10 22:09 UTC, Dusty Mabe
no flags Details

Description Adam Miller 2015-08-10 21:11:24 UTC
Description of problem:
Running docker-1.7.1-1.gitb6416b7.fc22.x86_64 the command 'docker create' will both create and run the container, when upgrading to 'docker-1.7.1-7.gitd5a81b3.fc22.x86_64' this is no longer the case.

Version-Release number of selected component (if applicable):
docker-1.7.1-7.gitd5a81b3.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:

$ docker --version
Docker version 1.7.1.fc22, build b6416b7/1.7.1

$ docker create --name test busybox
Unable to find image 'busybox:latest' locally
latest: Pulling from docker.io/busybox
cf2616975b4a: Pull complete 
6ce2e90b0bc7: Pull complete 
8c2e06607696: Already exists 
docker.io/busybox:latest: The image you are pulling has been verified. Important: image verification is a tech preview 
feature and should not be relied on to provide security.
Digest: sha256:38a203e1986cf79639cfb9b2e1d6e773de84002feea2d4eb006b52004ee8502d
Status: Downloaded newer image for docker.io/busybox:latest
ca36aabe0e0deafbde5a1ea253dd8f9ef37363da8f2a3f640eed878ae21b1f5c

$ docker cp test:/bin/busybox ./

$ ls -l busybox 
-rwsr-xr-x. 1 root root 561992 May 22  2014 busybox

$ docker stop test
test

$ docker rm test
test

$ docker rmi busybox
Untagged: busybox:latest
Deleted: 8c2e06607696bd4afb3d03b687e361cc43cf8ec1a4a725bc96e39f05ba97dd55
Deleted: 6ce2e90b0bc7224de3db1f0d646fe8e2c4dd37f1793928287f6074bc451a57ea
Deleted: cf2616975b4a3cba083ca99bc3f0bf25f5f528c3c52be1596b30f60b0b1c37ff

$ dnf update docker

$ docker --version
Docker version 1.7.1.fc22, build d5a81b3/1.7.1

$ docker create --name test busybox      
Unable to find image 'busybox:latest' locally
latest: Pulling from docker.io/busybox
cf2616975b4a: Pull complete 
6ce2e90b0bc7: Pull complete 
8c2e06607696: Already exists 
docker.io/busybox:latest: The image you are pulling has been verified. Important: image verification is a tech preview 
feature and should not be relied on to provide security.
Digest: sha256:38a203e1986cf79639cfb9b2e1d6e773de84002feea2d4eb006b52004ee8502d
Status: Downloaded newer image for docker.io/busybox:latest
a6665ee5b07506fb0988d896eed979ad0cfea9ba31f22044da00f9b6254d4db8

$ docker cp test:/bin/busybox ./                                                                                       
Error response from daemon: Could not find the file /bin/busybox in container test

Comment 1 Dusty Mabe 2015-08-10 22:09:58 UTC
Created attachment 1061266 [details]
A diff between a version of docker that worked and latest

Since it's not easy to trace the lineage of the docker code we have been using I have managed to get a diff of a version of docker where this worked (b6416b7) and the version where it doesn't work (d5a81b3). These commits are from https://github.com/rhatdan/docker.git but only one of them can be traced.

Comment 2 Lokesh Mandvekar 2015-08-14 18:12:00 UTC
docker-1.7.1-8 was a revert to what existed in 1.7.1-1, which would be a temp fix for this bug. -8 has landed in fedora-updates. Keeping this open for now though.

Comment 3 Daniel Walsh 2015-08-21 04:14:32 UTC
Fixed in docker-1.8

Comment 4 Dusty Mabe 2015-11-28 02:48:13 UTC
As dan said this is fixed in the docker 1.8 rpms.


Note You need to log in before you can comment on or make changes to this bug.