Bug 1252171 - f23-backgrounds-* should obsolete f22-backgrounds-*
f23-backgrounds-* should obsolete f22-backgrounds-*
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: desktop-backgrounds (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 17:20 EDT by Vít Ondruch
Modified: 2015-08-17 04:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 03:04:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2015-08-10 17:20:48 EDT
Description of problem:
f23-backgrounds-* should obsolete f22-backgrounds-*

I really don't understand why this is not done. Why should I kept f22-backgrounds-* on my system. Or better, why are the packages renamed on the first place?


Version-Release number of selected component (if applicable):
$ rpm -q desktop-backgrounds-gnome
desktop-backgrounds-gnome-23.0.0-1.fc24.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Martin Sourada 2015-08-11 03:04:18 EDT
They are different set of wallpapers, user should be able to install either of them, if you use them, they should not be replaced when you update/upgrade. Because we abandoned release names they are named less then elegant which probably causes this confusion you are showing. :(
Comment 2 Vít Ondruch 2015-08-11 08:40:06 EDT
The thing is that when I install F23, I'll get just f23-backgrounds-* but when I upgrade, then I have f23-backgrounds-* as well as f22-backgrounds-* on my system. I can't see why I should have both of them installed.

TBH, I am using just default background and I don't even care where it comes from.

Moreover, the "dnf autoremove" wants immediately to remove them (and that is correct IMO).

I don't really want to end up with f[1..Infinite]-background-* packages on my system.
Comment 3 Martin Sourada 2015-08-15 08:19:24 EDT
Upgrade will never be the same as clean install. I understand what you'd like, but I fear it being in direct conflict with the idea of how upgrades should work. I mean, defaults are (or at least should be) meant for new users, not existing users and f(n+1)-background* are not upgrades of f(n)-background*. They are different set of images, they are *not* intended to replace each other, just supply a new default. What prevents you from removing f(n-1)-background* after upgrade manually?
Comment 4 Vít Ondruch 2015-08-17 03:40:40 EDT
This is not upgrade, but Rawhide. Moreover, "dnf autoremove" will immediately try to remove the old backgrounds anyway, so I don't understand what is the point of keeping them on the system or versioning them in this way.
Comment 5 Martin Sourada 2015-08-17 04:51:48 EDT
Rawhide is different story altogether...

Anyway, dnf autoremove will remove it because the package gets installed as *a default* wallpaper by desktop-backgrounds and which is the default changes each release. If we replaced it, instead of creating a new one each release, there wouldn't be a way for current users of the background to keep it (unless downloading the images outside of the whole rpm system).

Note You need to log in before you can comment on or make changes to this bug.