Bug 1252201 - Feature Request: Allow virt-manager connection until libvirt-guests has shut down guests
Feature Request: Allow virt-manager connection until libvirt-guests has shut ...
Status: CLOSED CANTFIX
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 20:51 EDT by jamespharvey20
Modified: 2016-04-10 17:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-10 17:41:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jamespharvey20 2015-08-10 20:51:07 EDT
If I'm on my own system running virt-manager, remotely connected via QEMU/KVM/ssh/openbsd-netcat to a server running KVM/libvirt/QEMU, and I run "systemd reboot/poweroff" on that server, my client socket to the server immediately closes.

Makes sense, unless libvirt-guests is gracefully shutting down guests.  In that case, it would be nice to delay shutting down the client socket until all the guests were shut down, so I could watch the vm shutdown process through the virtual console.
Comment 1 Cole Robinson 2016-04-10 17:41:11 EDT
I think the problem is that when you trigger the host shutdown, systemd shuts off the ssh daemon fairly soon, which is what kills your virt-manager connection. Libvirtd is still running, since it needs to be running for libvirt-guests service to work. So I don't think this is anything that can be fixed on the libvirt side

Note You need to log in before you can comment on or make changes to this bug.