Bug 1252202 - managedsave/start fails because of Q35 UHCI Host Controller
managedsave/start fails because of Q35 UHCI Host Controller
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
: 1252203 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 20:58 EDT by jamespharvey20
Modified: 2016-05-02 10:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-02 10:35:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jamespharvey20 2015-08-10 20:58:48 EDT
managedsave/start appears to work, but VM is unusable due to non-stop
repeating uhci_hcd errors.

I can't remove the USB controller from QEMU, but I CAN remove it
through virsh edit.  Doing so eliminates the USB controller in the
guest, preventing non-stop repeating uhci_hcd errors.  (QEMU only lets
you remove the USB redirection entries, which didn't help.)

Using libvirt 1.2.18 (-1 Arch) and QEMU git-master (2.4.0.r40384.2d69736).

Installed using Q35 chipset.

I'm running QEMU git, which allows SCSI controller migration, so I can
attempt doing this.

==========
virsh # managedsave <vmname>

Domain <vmname> state saved by libvirt

virsh # start <vmname>
Domain <vmname> started

{{{ Then, viewing the VM console through QEMU, its screen is extremely
laggy, taking about a minute to fill up the screen with repeating
errors within 0.003 kernel seconds: }}}
uhci_hcd 0000:02:02.2: host system error, PCI problems?
uhci_hcd 0000:02:02.2: host controller process error, something bad happened!
{{{ repeats }}}
==========
{{{ after a forced reboot }}}
$ dmesg|grep 0000:02:02
[    0.480054] pci 0000:02:02.0: [8086:2934] type 00 class 0x0c0300
[    0.498451] pci 0000:02:02.0: reg 0x20: [io  0xc0e0-0xc0ff]
[    0.506965] pci 0000:02:02.1: [8086:2935] type 00 class 0x0c0300
[    0.525101] pci 0000:02:02.1: reg 0x20: [io  0xc100-0xc11f]
[    0.533634] pci 0000:02:02.2: [8086:2936] type 00 class 0x0c0300
[    0.554992] pci 0000:02:02.2: reg 0x20: [io  0xc120-0xc13f]
[    0.563642] pci 0000:02:02.7: [8086:293a] type 00 class 0x0c0320
[    0.566679] pci 0000:02:02.7: reg 0x10: [mem 0xfc041000-0xfc041fff]
[    1.720668] ehci-pci 0000:02:02.7: EHCI Host Controller
[    1.720709] ehci-pci 0000:02:02.7: new USB bus registered, assigned
bus number 1
[    1.721343] ehci-pci 0000:02:02.7: irq 22, io mem 0xfc041000
[    1.730198] ehci-pci 0000:02:02.7: USB 2.0 started, EHCI 1.00
[    1.740641] uhci_hcd 0000:02:02.0: UHCI Host Controller
[    1.740667] uhci_hcd 0000:02:02.0: new USB bus registered, assigned
bus number 2
[    1.740813] uhci_hcd 0000:02:02.0: detected 2 ports
[    1.741026] uhci_hcd 0000:02:02.0: irq 23, io base 0x0000c0e0
[    1.747517] uhci_hcd 0000:02:02.1: UHCI Host Controller
[    1.747543] uhci_hcd 0000:02:02.1: new USB bus registered, assigned
bus number 3
[    1.747664] uhci_hcd 0000:02:02.1: detected 2 ports
[    1.747904] uhci_hcd 0000:02:02.1: irq 20, io base 0x0000c100
[    1.753055] uhci_hcd 0000:02:02.2: UHCI Host Controller
[    1.753074] uhci_hcd 0000:02:02.2: new USB bus registered, assigned
bus number 4
[    1.753624] uhci_hcd 0000:02:02.2: detected 2 ports
[    1.753724] uhci_hcd 0000:02:02.2: irq 21, io base 0x0000c120
==========
Comment 1 Cole Robinson 2016-04-10 17:43:17 EDT
Can you still reproduce with latest libvirt and qemu?
Can you provide your full VM XML?

FWIW this is either a guest OS issue or qemu q35 migration/managedsave issue, I doubt libvirt is responsible here, but I can help triage
Comment 2 Cole Robinson 2016-04-10 17:48:06 EDT
*** Bug 1252203 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2016-05-02 10:35:47 EDT
Since there's no response, closing as DEFERRED. But if anyone is still affected with newer libvirt versions, please re-open and we can triage from there

Note You need to log in before you can comment on or make changes to this bug.