Bug 1252221 - sdhci_acpi no longer included in initramfs
sdhci_acpi no longer included in initramfs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
23
All Linux
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint-list
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 22:31 EDT by Adam Williamson
Modified: 2015-08-11 00:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 00:10:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2015-08-10 22:31:30 EDT
Some time ago I filed https://bugzilla.redhat.com/show_bug.cgi?id=1063556 ; this was addressed upstream. I just noticed it's broken again, though. I tried a new build of my 'fedlet' image and it didn't boot; sdhci_acpi is missing from the initramfs.

I suspect one of these two changes:

https://git.kernel.org/cgit/boot/dracut/dracut.git/commit/modules.d/90kernel-modules/module-setup.sh?id=6dcc5e1158bf502b431491a381a16ca894f99ae2

https://git.kernel.org/cgit/boot/dracut/dracut.git/commit/modules.d/90kernel-modules/module-setup.sh?id=6d58fa27a43833737143e0788097224a559808de

sdhci-acpi does seem to include sdhci_add_host , though, so the latter seems more likely.
Comment 1 Adam Williamson 2015-08-10 23:36:41 EDT
hmmm...actually, when I run dracut -f -N on an installed system, sdhci-acpi does wind up in the generated initramfs. But it doesn't show up in the initramfs in a newly-built live image. now I get to fiddle with live image initramfs generation...joy? I guess?
Comment 2 Adam Williamson 2015-08-11 00:10:33 EDT
eh, never mind, this isn't my problem. the live isn't booting for some other reason. the reason? damn if I know. grr.

Note You need to log in before you can comment on or make changes to this bug.