Bug 1252308 - Issues in postfix pmda's search for mail log
Issues in postfix pmda's search for mail log
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcp (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nathan Scott
Miloš Prchlík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 03:09 EDT by Miloš Prchlík
Modified: 2016-11-04 00:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:22:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloš Prchlík 2015-08-11 03:09:30 EDT
Description of problem:


The first issue that caught my attention, and caused my sanity test of postfix pmda to fail: test failed to install pmda, with these errors in pmcd/postfix.log:

[Tue Aug 11 02:53:58] pmdapostfix(27796) Info: qshape cmd: qshape -b 10 -t 5 <qname>
[Tue Aug 11 02:53:58] pmdapostfix(27796) Error: Data read error on tailed file: Is a directory

Which makes sense, after some digging it was obvious that /var/log/mail - present in @logfiles - is a directory. /var/log/mail is a directory, but readable, therefore it's used in qshape calls.


The second issue, pmdapostfix.pl, line 243 - I'm no friend with perl but I think there should be $pmda:

  pmda->log("Fatal: No Postfix log file found in: @logfiles");


Version-Release number of selected component (if applicable):

pcp-pmda-postfix-3.10.6-1.el7


How reproducible:

Always, on all arches


Steps to Reproduce:
1. service pmcd start
2. cd /var/lib/pcp/pmdas/postfix && ./Install
3.

Actual results:


Expected results:


Additional info:
Comment 1 Miloš Prchlík 2015-08-11 03:14:04 EDT
I made a tiny mistake, the correct messages in pmcd/postfix.log are:

[Fri Aug  7 05:24:14] pmdapostfix(64056) Info: qshape cmd: qshape -b 10 -t 5 <qname>
[Fri Aug  7 05:24:14] pmdapostfix(64056) Info: logfile: /var/log/mail
[Fri Aug  7 05:24:14] pmdapostfix(64056) Error: Data read error on tailed file: Is a directory
Comment 2 Nathan Scott 2015-08-13 03:37:39 EDT
(In reply to Miloš Prchlík from comment #0)
> [...]
> Which makes sense, after some digging it was obvious that /var/log/mail -
> present in @logfiles - is a directory. /var/log/mail is a directory, but
> readable, therefore it's used in qshape calls.
> 

Yep - easily defended against, fix headed upstream shortly.

> 
> The second issue, pmdapostfix.pl, line 243 - I'm no friend with perl but I
> think there should be $pmda:
> 
>   pmda->log("Fatal: No Postfix log file found in: @logfiles");
> 

Yes, good catch; perl is lenient on that, but also fixed upstream now.

I wouldn't think these issues are high enough priority for a rebuild at this stage, but we can pick them up in the context of other patches if any are needed.

thanks Miloš!
Comment 5 Miloš Prchlík 2016-08-20 07:11:40 EDT
Verified for build pcp-3.11.3-3.el7.
Comment 7 errata-xmlrpc 2016-11-04 00:22:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2344.html

Note You need to log in before you can comment on or make changes to this bug.