Bug 1252312 - HBase translator - date, time, timestamp values are not translated correctly
HBase translator - date, time, timestamp values are not translated correctly
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: 6.2.0
Assigned To: Van Halbert
Juraj Duráni
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 03:25 EDT by Juraj Duráni
Modified: 2016-02-10 03:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Hbase: 1.1.1 Phoenix: 4.5.0-HBase-1.1
Last Closed: 2016-02-10 03:58:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
insert (7.08 KB, text/plain)
2015-08-11 03:25 EDT, Juraj Duráni
no flags Details
select (7.56 KB, text/plain)
2015-08-11 03:26 EDT, Juraj Duráni
no flags Details
update (6.87 KB, text/plain)
2015-08-11 03:26 EDT, Juraj Duráni
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3620 Major Resolved HBase translator - date, time, timestamp values are not translated correctly 2015-09-15 17:52:26 EDT

  None (edit)
Description Juraj Duráni 2015-08-11 03:25:41 EDT
Created attachment 1061338 [details]
insert

Using date/time/timestamp value in SQL query causes an exception [1] -
{ts '...'}/{d '...'}/{t '...'} is not supported by Phoenix Driver.The issue is present in all types of statements (select, insert, update).
Comment 1 Juraj Duráni 2015-08-11 03:26:06 EDT
Created attachment 1061339 [details]
select
Comment 2 Juraj Duráni 2015-08-11 03:26:22 EDT
Created attachment 1061340 [details]
update

Note You need to log in before you can comment on or make changes to this bug.