Bug 125239 - pcmcia not working on ARM computer laptop
pcmcia not working on ARM computer laptop
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Depends On:
  Show dependency treegraph
Reported: 2004-06-03 19:31 EDT by Florin Andrei
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-25 15:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2004-06-03 19:31:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
Installed FC2 on an ARM Computer laptop. It's an old laptop, PII/266,
I plugged in the PCMCIA slots my Linksys WPC11 wireless card, and my
Dell/3Com 3CCFE575BT-D network card. These cards work fine with FC2 on
an equally old Dell laptop.

Apparently they got detected by the installer, because i got this in

alias eth0 3c59x
alias eth1 orinoco_cs

However, when running "service pcmcia start" i get this:

Starting PCMCIA services: cardmgr[2396]: no sockets found!

Needless to say, the two cards are not working.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install FC2 on ARM Computer laptop
2.start PCMCIA service

Actual Results:  cardmgr[2396]: no sockets found!

Expected Results:  PCMCIA should work fine

Additional info:
Comment 1 Alan Cox 2004-06-19 07:52:52 EDT
Does modprobe yenta_socket report finding sockets, and if not does
setting up /etc/sysconfig/pcmcia by hand help ?

(typically PCMCIA=yes PCIC=yenta_socket [or i82365]  
Comment 2 Florin Andrei 2004-06-24 01:31:47 EDT
(i'll copy/paste manually, since i don't have network access to the

I did a "modprobe yenta_socket". On the console, it said "spurious
8259A interrupt: IRQ7."
The module loaded up fine and it's listed as used by something
(there's a "1" in the "Used by" column).

I'm keeping a "*.* /dev/tty12" in syslog.conf so i can watch things
with Alt-F12. Sure enough, there was a bunch of messages on the 12th
console once i did the modprobe (i'm quoting sporadically): 

PCI: Found IRQ9 for device 0000:00:0a.0
PCI: Sharing IRQ9 with ...
Yenta: CardBus bridge found at...
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:00:0a.0, mfunc 0x00020000, devctl 0x66
Socket status: 30000006

Then similar messages for another socket.

In /etc/sysconfig/pcmcia there was already a PCMCIA=yes and
PCIC=yenta_socket. Isn't that the default?
So i just did a "/etc/init.d/pcmcia start" (with the yenta_socket
loaded manually) and it worked! My wireless card got a DHCP from my
access point (no, it's not what you think :-D it's not publicly

I'll reboot the system and try a few hacks then i'll post more results.
Comment 3 Florin Andrei 2004-06-24 02:10:28 EDT
Ok, if i do "modprobe yenta_socket" then "/etc/init.d/pcmcia start"
manually, then it works. I guess i could hack the scripts to do
modprobe before PCMCIA is actually started, but that's not a proper

If you guys want me to run commands, do tests, etc. just let me know.

BTW, since now i can manually bring the network up, i did a "yum
update" then i rebooted with the latest kernel, and the problem persists.
Comment 4 Florin Andrei 2004-09-15 14:32:53 EDT
Ok, i'm seeing exactly the same issue with a vanilla install of FC2 on
an old Dell Latitude CPi laptop. If i run "modprobe yenta_socket"
before, then "service pcmcia start" works fine, otherwise it doesn't.
Comment 5 Florin Andrei 2004-10-13 13:25:16 EDT
I reinstalled those machines several times, and i'm not able to find
what are the conditions required to reproduce the problem. It
sometimes happens, some other times it doesn't.

Anyway, if it happens, i know the solution:
I edit /etc/sysconfig/pcmcia and add, at the end of the file, this line:

/sbin/modprobe yenta_socket

This probably forces the module to be loaded and fixes the problem.
It looks like, for whatever reason, that module is not automatically
loaded in some conditions.
Comment 6 Matthew Miller 2005-04-26 11:23:08 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 7 John Thacker 2006-10-25 15:31:26 EDT
Closed per above message and lack of response.  Note that FC2 is not even
supported by Fedora Legacy currently.

Note You need to log in before you can comment on or make changes to this bug.