Bug 1252392 - Ipsilon does not have any SQL indexes
Ipsilon does not have any SQL indexes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipsilon (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Patrick Uiterwijk
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 06:18 EDT by Patrick Uiterwijk
Modified: 2015-11-19 05:50 EST (History)
5 users (show)

See Also:
Fixed In Version: ipsilon-1.0.0-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 05:50:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Uiterwijk 2015-08-11 06:18:53 EDT
Ipsilon 1.0.0 does not have any SQL indexes, which will make it very slow after using it some time.

There is a patch up for review upstream, and we should make sure the first RHEL release has this patch applied as well.
Comment 4 Patrick Uiterwijk 2015-09-07 21:50:56 EDT
This was merged upstream previously: 61de77fc7eae1f844944bd692d13bf27a1fda6fe
Comment 7 Scott Poore 2015-09-08 19:01:51 EDT
Verified.

Version ::

ipsilon-1.0.0-9.el7.noarch

Results ::

First on previous version:
1.0.0-8.el7

[root@idp idp]# sqlite3 /var/lib/ipsilon/idp/adminconfig.sqlite 
...
sqlite> .indices saml2_data;
sqlite>

Then on new version (after uninstall/reinstall using ipsilon-server-install):
ipsilon-1.0.0-9.el7.noarch

[root@idp idp]# sqlite3 /var/lib/ipsilon/idp/adminconfig.sqlite ".indices saml2_data"
idx_saml2_data_uuid
sqlite_autoindex_saml2_data_1
Comment 8 errata-xmlrpc 2015-11-19 05:50:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2319.html

Note You need to log in before you can comment on or make changes to this bug.