Bug 1252406 - openjdk-headless 1.8.0.51 has a %postun scriptlet error that break java if reinstalled
openjdk-headless 1.8.0.51 has a %postun scriptlet error that break java if re...
Status: CLOSED DUPLICATE of bug 1200302
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
: Reopened
Depends On: 1260702
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 06:30 EDT by Heldwin
Modified: 2016-07-12 05:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-12 05:05:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heldwin 2015-08-11 06:30:42 EDT
Description of problem:
java-1.8.0-openjdk-headless has a %postun scriptlet error that will break java if reinstalled.

Not sure yet if it will do an error updating to the next version. When I remove this package with: rpm -e --nodeps, it tells a %postun scriptlet error, exit 2

The only way I have found is to remove it and install it.


Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-headless-1:1.8.0.51-4.b16.fc22.x86_64 


How reproducible:
always


Steps to Reproduce:
1. install java-1.8.0-openjdk-headless-1:1.8.0.51-4.b16.fc22.x86_64 
2. which java, or: alternatives --display java -> returns a java
3. dnf reinstall java-1.8.0-openjdk-headless-1:1.8.0.51-4.b16.fc22.x86_64 
4. which java, or: alternatives --display java -> returns nothing
Comment 1 Heldwin 2015-08-11 08:20:05 EDT
D: %postun(java-1.8.0-openjdk-headless-1:1.8.0.51-4.b16.fc22.x86_64): scriptlet start
fdio:       2 writes,      404 total bytes in 0.000025 secs
D: %postun(java-1.8.0-openjdk-headless-1:1.8.0.51-4.b16.fc22.x86_64): execv(/bin/sh) pid 26611
D: Plugin: calling hook scriptlet_fork_post in selinux plugin
D: setexeccon: (/bin/sh, unconfined_u:unconfined_r:rpm_script_t:s0-s0:c0.c1023) 
+ alternatives --remove java /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.51-4.b16.fc22.x86_64/jre/bin/java
+ alternatives --remove jre_openjdk /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.51-4.b16.fc22.x86_64/jre
+ alternatives --remove jre_1.8.0 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.51-4.b16.fc22.x86_64/jre
+ alternatives --remove jre_1.8.0_openjdk /usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.51-4.b16.fc22.x86_64
D: %postun(java-1.8.0-openjdk-headless-1:1.8.0.51-4.b16.fc22.x86_64): waitpid(26811) rc 26811 status 200
warning: %postun(java-1.8.0-openjdk-headless-1:1.8.0.51-4.b16.fc22.x86_64) scriptlet failed, exit status 2

------------------------------------------------------------------------------

It does the same if I run these alternatives --remove commands after a clean install, and then if I try to remove it. 

Would it be because during the reinstall, the %postun remove them during the remove, but does not add them again for install ?
Comment 2 jiri vanek 2015-08-11 08:28:43 EDT
Maybe....

Currently I dont know what is wrong with dnf. As you cans ee, the behaviour is ok with yum.

*** This bug has been marked as a duplicate of bug 1200302 ***
Comment 3 jiri vanek 2016-07-12 05:05:27 EDT

*** This bug has been marked as a duplicate of bug 1200302 ***

Note You need to log in before you can comment on or make changes to this bug.