Bug 1252408 - [oVirt Live] NullPointerException after "Restarting httpd."
[oVirt Live] NullPointerException after "Restarting httpd."
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Ravi Nori
Pavol Brilla
: Regression
Depends On: 1267222
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 06:39 EDT by Nika Burimenko
Modified: 2016-02-10 07:50 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 07:50:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.0?
rule-engine: blocker?
ylavi: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Nika Burimenko 2015-08-11 06:39:50 EDT
Description of problem:
I'm trying to run oVirt Live with CentOS 7, because standard image with CentOS 6 is not working anymore for HW problem or something.
But during oVirt setup process I'm getting NullPointerException, which happens right after "Restarting httpd". Here are logs of setup:
http://pastebin.com/xRr6rAVZ
http://pastebin.com/j0juRiHV

Version-Release number of selected component (if applicable):
ovirt-live-el7-master.1508110411.iso


How reproducible:
always.

Steps to Reproduce:
1. Make USB-flash of oVirt Live based on CentOS 7 with Fedora LiveUSB Creator.
2. Boot from USB.
3. Run automatic oVirt setup.

Actual results:
Failed setup with NullPointerException after "Restarting httpd."

Expected results:
Succeeded setup with working oVirt.

Additional info:
Comment 1 Sandro Bonazzola 2015-08-18 10:16:18 EDT
2015-08-11 12:26:00,963 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (default task-5) [] Exception: javax.ejb.EJBException: java.lang.NullPointerException

Moving to ovirt-engine-api, infra vertical.
Comment 2 Juan Hernández 2015-08-18 10:34:19 EDT
The relevant part of the log is the following:

Caused by: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.Backend.evaluateCorrelationId(Backend.java:485)
	at org.ovirt.engine.core.bll.Backend.runAction(Backend.java:468)
	at org.ovirt.engine.core.bll.Backend.runActionImpl(Backend.java:457)
	at org.ovirt.engine.core.bll.Backend.runAction(Backend.java:413)

And the code at Backend.java:485 is like this:

  returnValue = ExecutionHandler.evaluateCorrelationId(commandBase.getParameters());

The only way that a NPE can be generated there is if "commandBase" is null. That "commandBase" parameter is generated in the "runActionImpl" method as follows:

  CommandBase<?> command = CommandsFactory.createCommand(actionType, parameters, context);
  result = runAction(command, runAsInternal);

So I think that the problem is that this code is running at a point where the backend isn't yet completely initialized, maybe before some dependencies are injected.

The RESTAPI takes the Backend object from the JNDI java:global name space, and it assumes that is is completely initialized. The backend needs to make sure that everything is completely initialized before the EJB is registered in the JNDI java:global environment. This usually means making sure that all the initialization has been completed before finishing the @PostConstruct method.
Comment 3 Red Hat Bugzilla Rules Engine 2015-09-22 03:43:53 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Oved Ourfali 2015-09-24 01:20:42 EDT
Sandro - does it still happen?
Comment 5 Red Hat Bugzilla Rules Engine 2015-09-24 08:34:38 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 6 Sandro Bonazzola 2015-09-30 04:53:12 EDT
Can't reproduce with http://plain.resources.ovirt.org/pub/ovirt-3.6-pre/iso/ovirt-live/el7-rc1/ovirt-live-el7-rc1.iso

Nika, can you please verify on your system?
Comment 7 Sandro Bonazzola 2015-09-30 04:54:34 EDT
Ravi, I suggest to re-target to 3.6.0-rc since it looks like it has been fixed there
Comment 8 Nika Burimenko 2015-10-06 23:53:03 EDT
(In reply to Sandro Bonazzola from comment #6)
> Can't reproduce with
> http://plain.resources.ovirt.org/pub/ovirt-3.6-pre/iso/ovirt-live/el7-rc1/
> ovirt-live-el7-rc1.iso
> 
> Nika, can you please verify on your system?

Sorry for long response. Yes, it now works with this build.
Comment 9 Red Hat Bugzilla Rules Engine 2015-10-18 04:21:30 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 10 Red Hat Bugzilla Rules Engine 2015-10-19 06:49:15 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 11 Pavol Brilla 2016-01-21 08:50:09 EST
Based on comment 8 put to verified

Note You need to log in before you can comment on or make changes to this bug.