Bug 1252436 - using timer probes gets a compilation error
using timer probes gets a compilation error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Frank Ch. Eigler
Martin Cermak
:
Depends On:
Blocks: 1246123
  Show dependency treegraph
 
Reported: 2015-08-11 08:13 EDT by Martin Cermak
Modified: 2015-11-19 06:47 EST (History)
4 users (show)

See Also:
Fixed In Version: systemtap-2.8-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:47:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Cermak 2015-08-11 08:13:28 EDT
Using systemtap-2.8-7.el7.aarch64 running on top kernel kernel-4.2.0-0.rc3.16.el7.aarch64, I see:

=======
S aarch64 # stap -v -e 'probe timer.s(1){exit()}'
Pass 1: parsed user script and 107 library script(s) using 159168virt/43712res/6080shr/34112data kb, in 320usr/20sys/336real ms.
Pass 2: analyzed script: 1 probe(s), 1 function(s), 0 embed(s), 0 global(s) using 159744virt/43712res/6080shr/34688data kb, in 0usr/0sys/8real ms.
Pass 3: translated to C into "/tmp/stapeN1Im7/stap_3e021ce615d9cb7006177abf2e62a68e_969_src.c" using 159744virt/46016res/7168shr/34688data kb, in 0usr/0sys/0real ms.
In file included from /usr/share/systemtap/runtime/timer.c:17:0,
                 from /tmp/stapeN1Im7/stap_3e021ce615d9cb7006177abf2e62a68e_969_src.c:175:
/usr/share/systemtap/runtime/linux/timer.c: In function ‘_stp_hrtimer_init’:
/usr/share/systemtap/runtime/linux/timer.c:19:2: error: implicit declaration of function ‘hrtimer_get_res’ [-Werror=implicit-function-declaration]
  hrtimer_get_res (CLOCK_MONOTONIC, &res);
  ^
cc1: all warnings being treated as errors
make[1]: *** [/tmp/stapeN1Im7/stap_3e021ce615d9cb7006177abf2e62a68e_969_src.o] Error 1
make: *** [_module_/tmp/stapeN1Im7] Error 2
WARNING: kbuild exited with status: 2
Pass 4: compiled C into "stap_3e021ce615d9cb7006177abf2e62a68e_969.ko" in 5780usr/240sys/7153real ms.
Pass 4: compilation failed.  [man error::pass4]
S aarch64 # vim /usr/share/systemtap/runtime/linux/timer.c
S aarch64 # uname -r
4.2.0-0.rc3.16.el7.aarch64
S aarch64 # 
=======

This appears to be fixed upstream in PR18634, commit 86f726b7785a035a2d6bc9ec2642c46621587d23. Please, backport.
Comment 1 Martin Cermak 2015-08-11 10:27:15 EDT
Looks fine with systemtap-2.8-8.el7. Thanks!
Comment 4 errata-xmlrpc 2015-11-19 06:47:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2124.html

Note You need to log in before you can comment on or make changes to this bug.