Bug 1252449 - "yum update kernel" produces invalid initramfs if there is no space in /boot
"yum update kernel" produces invalid initramfs if there is no space in /boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Harald Hoyer
Release Test Team
:
Depends On:
Blocks: 1270825
  Show dependency treegraph
 
Reported: 2015-08-11 08:49 EDT by Ondrej
Modified: 2016-05-10 21:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 21:09:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0954 normal SHIPPED_LIVE dracut bug fix and enhancement update 2016-05-10 18:56:39 EDT

  None (edit)
Description Ondrej 2015-08-11 08:49:52 EDT
Description of problem:
When upgrading a kernel on a machine witch not sufficient space in /boot, dracut produces an invalid initramfs. No warning/error message is displayed.
Machine can not boot after that

How reproducible:
always

Steps to Reproduce:
1. make sure there is little space in /boot (say 10Mb)
2. run "yum update kernel"
3.

Actual results:
initramfs for the new kernel is produced, but it is incomplete.
No warning/error message is displayed

Expected results:
dracut should complain loudly if there is insufficient space in /boot

Additional info:
Comment 7 errata-xmlrpc 2016-05-10 21:09:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0954.html

Note You need to log in before you can comment on or make changes to this bug.