Bug 1252450 - blivet.errors.DeviceError: ('cannot replace active format', 'fedora_dhcp42-root')
blivet.errors.DeviceError: ('cannot replace active format', 'fedora_dhcp42-ro...
Status: CLOSED DUPLICATE of bug 1252052
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: blivet-maint-list@redhat.com
Fedora Extras Quality Assurance
abrt_hash:37a26951cbba423c77d289aef46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 08:56 EDT by Jiri Konecny
Modified: 2015-08-12 03:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 03:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (361.96 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: anaconda.log (20.68 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: dnf.log (1.27 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: environ (494 bytes, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: lsblk_output (1.40 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: nmcli_dev_list (1.52 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: os_info (451 bytes, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: storage.log (143.10 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: syslog (64.13 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: ifcfg.log (1.65 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: packaging.log (1.53 KB, text/plain)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details
File: program.log (76.32 KB, application/octet-stream)
2015-08-11 08:56 EDT, Jiri Konecny
no flags Details

  None (edit)
Description Jiri Konecny 2015-08-11 08:56:12 EDT
Description of problem:
Anaconda crash when automatic partitioning is used.

Version-Release number of selected component:
anaconda-23.19-1

The following was filed automatically by anaconda:
anaconda 23.19-1 exception report
Traceback (most recent call first):
  File "/tmp/updates/blivet/devices/storage.py", line 697, in _setFormat
    raise errors.DeviceError("cannot replace active format", self.name)
  File "/tmp/updates/blivet/devices/lvm.py", line 646, in _setFormat
    super(LVMLogicalVolumeDevice, self)._setFormat(fmt)
  File "/tmp/updates/blivet/devices/storage.py", line 742, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/tmp/updates/blivet/deviceaction.py", line 669, in apply
    self.device.format = None
  File "/tmp/updates/blivet/devicetree.py", line 323, in registerAction
    action.apply()
  File "/tmp/updates/blivet/devicetree.py", line 275, in recursiveRemove
    self.registerAction(ActionDestroyFormat(leaf))
  File "/tmp/updates/blivet/blivet.py", line 611, in recursiveRemove
    self.devicetree.recursiveRemove(device)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/lib/resize.py", line 422, in _recursiveRemove
    self.storage.recursiveRemove(device)
  File "/tmp/updates/pyanaconda/ui/gui/spokes/lib/resize.py", line 447, in _scheduleActions
    self._recursiveRemove(device)
blivet.errors.DeviceError: ('cannot replace active format', 'fedora_dhcp42-root')

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   initrd=/test/jk/rawhide/initrd.img inst.repo=ftp://cobra02/rawhide/x86_64/os nokill resolution=1024x768 updates=http://cobra02/ks/jk/master_updates.img BOOT_IMAGE=/test/jk/rawhide/vmlinuz 
dnf.rpm.log:    Aug 11 12:53:25 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc3.git4.1.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        Rawhide
Comment 1 Jiri Konecny 2015-08-11 08:56:16 EDT
Created attachment 1061504 [details]
File: anaconda-tb
Comment 2 Jiri Konecny 2015-08-11 08:56:17 EDT
Created attachment 1061505 [details]
File: anaconda.log
Comment 3 Jiri Konecny 2015-08-11 08:56:19 EDT
Created attachment 1061506 [details]
File: dnf.log
Comment 4 Jiri Konecny 2015-08-11 08:56:20 EDT
Created attachment 1061507 [details]
File: environ
Comment 5 Jiri Konecny 2015-08-11 08:56:21 EDT
Created attachment 1061508 [details]
File: lsblk_output
Comment 6 Jiri Konecny 2015-08-11 08:56:23 EDT
Created attachment 1061509 [details]
File: nmcli_dev_list
Comment 7 Jiri Konecny 2015-08-11 08:56:24 EDT
Created attachment 1061510 [details]
File: os_info
Comment 8 Jiri Konecny 2015-08-11 08:56:26 EDT
Created attachment 1061511 [details]
File: storage.log
Comment 9 Jiri Konecny 2015-08-11 08:56:29 EDT
Created attachment 1061512 [details]
File: syslog
Comment 10 Jiri Konecny 2015-08-11 08:56:30 EDT
Created attachment 1061513 [details]
File: ifcfg.log
Comment 11 Jiri Konecny 2015-08-11 08:56:31 EDT
Created attachment 1061514 [details]
File: packaging.log
Comment 12 Jiri Konecny 2015-08-11 08:56:33 EDT
Created attachment 1061515 [details]
File: program.log
Comment 13 Jiri Konecny 2015-08-11 09:53:32 EDT
I think this bug also cause that I can't remove existing '/' partition in custom partitioning.

I got warning:
('cannot replace active format', 'fedora_dhcp42-root')
Comment 14 Vratislav Podzimek 2015-08-12 03:56:04 EDT

*** This bug has been marked as a duplicate of bug 1252052 ***

Note You need to log in before you can comment on or make changes to this bug.