Bug 1252476 - no way to specify embedded proxy affinity for multi-datastore environments
no way to specify embedded proxy affinity for multi-datastore environments
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.4.2
Assigned To: Harpreet Kataria
Ramesh A
: ZStream
Depends On: 1246655
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 10:03 EDT by Chris Pelland
Modified: 2015-09-09 09:09 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.4.2.0
Doc Type: Bug Fix
Doc Text:
The previous version of CloudForms Management Engine removed support for external smart proxies, which resulted in losing the ability to define CFME appliance affinity for virtual machines created in environments with multiple appliances supporting multiple Datastores. This bug was fixed by retrieving the Smartproxy Affinity tab under Configuration. It is possible to specify SmartProxy Affinity in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1246655
Environment:
Last Closed: 2015-09-09 08:26:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-08-11 18:22:57 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e9e2957f5cb70c9a6df00ddffa19b9d69f1dac18

commit e9e2957f5cb70c9a6df00ddffa19b9d69f1dac18
Merge: 9ebb102 5b71bc5
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Aug 11 18:14:40 2015 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Aug 11 18:14:40 2015 -0400

    Merge branch '54z_bz_1246655' into '5.4.z'
    
    Recovered "Smartproxy Affinity" tab in Configuration.
    
    Recovered "Smartproxy Affinity" tab in Configuration explorer that was removed in https://github.com/ManageIQ/manageiq/pull/1531 along with all Smartproxy related code from UI in commit SHA: dd539dccd0289914df55ad81b7b977372dfcc647
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1246655
    https://bugzilla.redhat.com/show_bug.cgi?id=1252476
    
    @dclarizio please review. Had to make some changes manually to all_tabs view since tabs on upstream have been converted to patternfly tabs. Also had to make minor change to toolbar code in application_helper as that code has been moved out to a different module on upstream.
    original PR: https://github.com/ManageIQ/manageiq/pull/3783
    
    See merge request !218

 vmdb/app/assets/javascripts/miq_dynatree.js        |   9 +
 .../controllers/ops_controller/settings/common.rb  | 132 +++++++++++-
 vmdb/app/helpers/application_helper.rb             |   2 +-
 vmdb/app/views/ops/_all_tabs.html.haml             |   4 +
 .../_settings_smartproxy_affinity_tab.html.haml    |   3 +
 vmdb/app/views/ops/_smartproxy_affinity.html.haml  |  19 ++
 .../ops_controller/settings/common_spec.rb         | 236 +++++++++++++++++++++
 vmdb/spec/routing/ops_routing_spec.rb              |   1 +
 8 files changed, 404 insertions(+), 2 deletions(-)
Comment 3 CFME Bot 2015-08-11 18:23:01 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5b71bc5bee55b4484db24cde4123f5f6e37d6eea

commit 5b71bc5bee55b4484db24cde4123f5f6e37d6eea
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Aug 11 10:59:22 2015 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Aug 11 17:00:01 2015 -0400

    Recovered "Smartproxy Affinity" tab in Configuration.
    
    Recovered "Smartproxy Affinity" tab in Configuration explorer that was removed in https://github.com/ManageIQ/manageiq/pull/1531 along with all Smartproxy related code from UI in commit SHA: dd539dccd0289914df55ad81b7b977372dfcc647
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1246655
    https://bugzilla.redhat.com/show_bug.cgi?id=1252476

 vmdb/app/assets/javascripts/miq_dynatree.js        |   9 +
 .../controllers/ops_controller/settings/common.rb  | 132 +++++++++++-
 vmdb/app/helpers/application_helper.rb             |   2 +-
 vmdb/app/views/ops/_all_tabs.html.haml             |   4 +
 .../_settings_smartproxy_affinity_tab.html.haml    |   3 +
 vmdb/app/views/ops/_smartproxy_affinity.html.haml  |  19 ++
 .../ops_controller/settings/common_spec.rb         | 236 +++++++++++++++++++++
 vmdb/spec/routing/ops_routing_spec.rb              |   1 +
 8 files changed, 404 insertions(+), 2 deletions(-)
 create mode 100644 vmdb/app/views/ops/_settings_smartproxy_affinity_tab.html.haml
 create mode 100644 vmdb/app/views/ops/_smartproxy_affinity.html.haml
 create mode 100644 vmdb/spec/controllers/ops_controller/settings/common_spec.rb
Comment 9 Ramesh A 2015-08-27 05:11:21 EDT
Good to go.  Verified and working fine in 5.4.2.0.20150820153254_83e434d
Comment 12 errata-xmlrpc 2015-09-09 08:26:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1744.html

Note You need to log in before you can comment on or make changes to this bug.