Bug 1252480 - "new game" button disappears when not run in gnome 3 desktop
"new game" button disappears when not run in gnome 3 desktop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: swell-foop (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yanko Kaneti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 10:14 EDT by Tom Horsley
Modified: 2015-08-22 18:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.16.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-22 18:50:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fvwm test (104.82 KB, image/png)
2015-08-11 11:29 EDT, Yanko Kaneti
no flags Details
proposed fix (1.60 KB, patch)
2015-08-11 12:08 EDT, Yanko Kaneti
no flags Details | Diff
fixed (116.04 KB, image/png)
2015-08-11 12:19 EDT, Yanko Kaneti
no flags Details

  None (edit)
Description Tom Horsley 2015-08-11 10:14:07 EDT
Description of problem:

When run in the "normal" gnome 3 desktop environment there is a "new game" button with a little circular arrow icon in the top left of the menu bar area in the swell-foop app. There is also the totally insane mac-like menu up in the common gnome 3 menu bar four miles away from the actual app window (the primary reason I always hated macs and now hate gnome 3 as well :-).

When run in a non-gnome 3 environment with a sane window manager the toolkit apparently places the application menu button directly on top of the "new game" button, so now there is no way to get a new game started within the app.


Version-Release number of selected component (if applicable):
swell-foop-3.16.1-1.fc22.x86_64


How reproducible:
100%

Steps to Reproduce:
1.run swell-foop outside of a gnome 3 desktop.
2.
3.

Actual results:
no new game button

Expected results:
new game button

Additional info:
Comment 1 Yanko Kaneti 2015-08-11 10:37:08 EDT
Thanks, but you could be more specific than "sane". Which desktop environment is that so that we can try to reproduce it...

And its probably a good idea to report these upstream...
Comment 2 Tom Horsley 2015-08-11 11:01:16 EDT
I'm pretty sure any desktop not named "gnome 3" will show the same behavior. I use fvwm, I've seen someone say the same thing happens in kde.
Comment 3 Michael Catanzaro 2015-08-11 11:04:50 EDT
I cannot reproduce. App menu is supposed to appear to the left of the new game button (and does for me).

(Unfortunately the blocks don't fill the entire clutter view in this case; there is a wedge of black on the edge of the screen. But this is an unrelated bug.)
Comment 4 Yanko Kaneti 2015-08-11 11:29:10 EDT
Created attachment 1061565 [details]
fvwm test

Do you mean this ?
Comment 5 Tom Horsley 2015-08-11 12:07:50 EDT
(In reply to Yanko Kaneti from comment #4)
> Created attachment 1061565 [details]
> fvwm test
> 
> Do you mean this ?

Yep, the the circular arrow is gone and the application menu button is where it used to be.

>(Unfortunately the blocks don't fill the entire clutter view in this case; there >is a wedge of black on the edge of the screen. But this is an unrelated bug.)

I saw that too, but weirdly it only seems to happen on the first run, subsequent runs fill in the blocks OK.
Comment 6 Yanko Kaneti 2015-08-11 12:08:21 EDT
Created attachment 1061580 [details]
proposed fix

This fixes it for me here. The patch is against master but should apply to gnome-3-16
Michael ?
Comment 7 Yanko Kaneti 2015-08-11 12:19:30 EDT
Created attachment 1061608 [details]
fixed

This is how it looks with the fix applied
Comment 8 Tom Horsley 2015-08-11 13:42:34 EDT
Looks good to me!
Comment 9 Michael Catanzaro 2015-08-12 03:40:47 EDT
Aha, so it was previously hidden intentionally because New Game was in the app menu. But as of 3.16 it's not anymore [1]. I would rather not add it back, so this patch is the best approach; thanks Yanko! Please push to master and gnome-3-16.

[1] https://git.gnome.org/browse/swell-foop/commit/src?id=6d975a6d3f4fc4164a4e3976dd009138dd5e2b47
Comment 10 Yanko Kaneti 2015-08-12 04:26:15 EDT
Thanks Michael, 

Pushed to both master and gnome-3-16
any plans for a release on 3-16 or should we do the bodhi update dance just with this patch.
Comment 11 Michael Catanzaro 2015-08-12 05:38:28 EDT
I did a new upstream release. Yanko, do you want to handle the Fedora update?
Comment 12 Fedora Update System 2015-08-12 06:22:26 EDT
swell-foop-3.16.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/swell-foop-3.16.2-1.fc22
Comment 13 Fedora Update System 2015-08-13 12:55:53 EDT
Package swell-foop-3.16.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing swell-foop-3.16.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13394/swell-foop-3.16.2-1.fc22
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2015-08-22 18:49:59 EDT
swell-foop-3.16.2-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.