Bug 125249 - pls put back installation from floppy disk
pls put back installation from floppy disk
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-03 22:57 EDT by Bugzkilla
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 02:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bugzkilla 2004-06-03 22:57:31 EDT
Description of problem:
unable to install using floppy disk(s)

Version-Release number of selected component (if applicable):
n/a

How reproducible:
always

Steps to Reproduce:
1. look for floppy images in order to perform network install via 
ftp/http
2. can't find any
3. can't boot installer on a system with no CD/DVD drive
  
Actual results:
can't boot installer using floppy

Expected results:
being able to create a (set of) floppy disk(s) to boot the installer

Additional info:
there are systems out there without CD/DVD driver where users would 
like to install gnu/linux using a bootable floppy disk and perform a 
network installation
Comment 1 Jeremy Katz 2004-06-04 02:10:07 EDT
Unfortunately, this isn't doable due to the increase in size with the
2.6 kernel.  For systems without a floppy drive, other available
options include
a) Using diskboot.img on a USB pendrive or similar
b) PXE booting
c) Booting the kernel and initrd from an already installed linux system
Comment 2 Michael De La Rue 2004-09-02 12:20:05 EDT
There is a relatively simple solution which is adopted in Debian.  

a) minimal floppy installer with ONLY hdd drivers, possibly based on
very old kernel.
b) disk image split over floppies

1) boot from a
2) a automatically demands b and copies to hard disk
3) boot from hard disk.  

Thus the 2.6 kernel doesn't have to be written to disk. 

There should be other variations on the "just enough to get it written
to disk", probably even ones which could be written in a short number
of instructions e.g.
  - split the installation image across a few disks
  - take a rescue floppy and boot from it
  - make a free partition
  - copy the disks to the hdd 
   - insert floppy 1
      dd if=/dev/fd0 of=/dev/hdaX 
   - insert floppy 2
      dd if=/dev/fd0 of=/dev/hdaX bs=1024 skip=1440
   - insert floppy 3
      dd if=/dev/fd0 of=/dev/hdaX bs=1024 skip=2880
      .... 
   - rinse and repeat 
  - insert boot floppy with GRUB.
  - boot into GRUB
  - use grub to boot from hard disk.  

Never tested and no idea if this would work with the current images,
but it's worth a go.  

Note You need to log in before you can comment on or make changes to this bug.