Bug 1252498 - 'test-limits' test fails on ppc64le
'test-limits' test fails on ppc64le
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: orc (Show other bugs)
7.2
ppc64le Unspecified
low Severity low
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 10:40 EDT by Vadim Rutkovsky
Modified: 2015-11-19 03:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:19:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Rutkovsky 2015-08-11 10:40:45 EDT
Description of problem:
Make check fails on ppc64le

Version-Release number of selected component (if applicable):
orc-0.4.22-3.el7.ppc64le

How reproducible:
Always

Steps to Reproduce:
1. Run make check in orc's buildroot

Actual results:
PASS: abi
FAIL: test-limits


Expected results:
All tests pass (same as on x86_64 and ppc64)

Additional info:
See full test log at https://desktopqe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/desktop-orc-RHEL-7.2-2-runtest/20/artifact/testresults-FAKE/Test00_upstream-testset.log
Comment 1 Wim Taymans 2015-08-12 03:23:14 EDT
Can I get access to the machine to debug the issue?
Comment 5 Wim Taymans 2015-08-12 06:20:49 EDT
OK, it's not really an error in ORC, the unit test just doesn't deal well with the fact that there is no backend for PPC64.
Comment 6 Wim Taymans 2015-08-12 07:05:23 EDT
Not exactly an easy fix. We need a way to clear the error on the program so that the unit test can ignore the compilation error and then check the real error (adding too many constants).
Comment 7 Wim Taymans 2015-08-12 12:26:27 EDT
I have a simple fix pushed upstream, I can apply this to the rhel-7.2 package.
Comment 9 Vadim Rutkovsky 2015-09-01 07:44:36 EDT
Verified on orc-0.4.22-4.el7.ppc64le
Comment 10 errata-xmlrpc 2015-11-19 03:19:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2116.html

Note You need to log in before you can comment on or make changes to this bug.