Bug 1252504 - gnocchi-dbsync fails to run due to missed module
gnocchi-dbsync fails to run due to missed module
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-pytimeparse (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: z1
: 7.0 (Kilo)
Assigned To: Pradeep Kilambi
Yurii Prokulevych
: Rebase, TechPreview, Triaged, ZStream
Depends On:
Blocks: 1293176
  Show dependency treegraph
 
Reported: 2015-08-11 10:49 EDT by Yurii Prokulevych
Modified: 2015-12-20 20:14 EST (History)
5 users (show)

See Also:
Fixed In Version: python-pytimeparse-1.1.5-1.el7ost
Doc Type: Technology Preview
Doc Text:
With this update, the package python-pytimeparse is rebased to version 1.1.5 for openstack-gnocchi, so that gnocchi-dbsync can work successfully without any ImportErrors.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 13:37:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yurii Prokulevych 2015-08-11 10:49:29 EDT
Description of problem:
When trying to run gnocchi-dbsync got next error:

Traceback (most recent call last):
  File "/usr/bin/gnocchi-dbsync", line 6, in <module>
    from gnocchi.cli import storage_dbsync
  File "/usr/lib/python2.7/site-packages/gnocchi/cli.py", line 15, in <module>
    from gnocchi.indexer import sqlalchemy as sql_db
  File "/usr/lib/python2.7/site-packages/gnocchi/indexer/sqlalchemy.py", line 31, in <module>
    from gnocchi import utils
  File "/usr/lib/python2.7/site-packages/gnocchi/utils.py", line 19, in <module>
    from pytimeparse import timeparse
  File "/usr/lib/python2.7/site-packages/pytimeparse/__init__.py", line 28, in <module>
    from .timeparse import timeparse as parse
  File "/usr/lib/python2.7/site-packages/pytimeparse/timeparse.py", line 34, in <module>
    from builtins import dict, int
ImportError: No module named builtins

Additional info:
Looks like it requires newer version of pytimeparse. Similar request in rhbz:1215261
Comment 4 Pradeep Kilambi 2015-08-12 11:07:47 EDT
python-pytimeparse rebased to 1.1.5 in brew:

https://brewweb.devel.redhat.com/buildinfo?buildID=451989

moving to Modified.
Comment 6 Yurii Prokulevych 2015-08-24 08:41:35 EDT
Successfully run gnocchi-dbsync <excerpt from the output>:
...
2015-08-24 08:17:26.590 2344 DEBUG oslo_db.sqlalchemy.session [-] MySQL server mode set to STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE
_USER,NO_ENGINE_SUBSTITUTION _check_effective_sql_mode /usr/lib/python2.7/site-packages/oslo_db/sqlalchemy/session.py:513


Packages:
openstack-gnocchi-doc-1.0.0-4.el7ost.noarch
openstack-gnocchi-carbonara-1.0.0-4.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-1.0.0-4.el7ost.noarch
openstack-gnocchi-api-1.0.0-4.el7ost.noarch
python-gnocchi-1.0.0-4.el7ost.noarch
openstack-gnocchi-statsd-1.0.0-4.el7ost.noarch
python-pytimeparse-1.1.5-1.el7ost.noarch
Comment 9 errata-xmlrpc 2015-09-03 13:37:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1721

Note You need to log in before you can comment on or make changes to this bug.