Bug 1252518 - [abrt] python-dnf: repo.py:793:load:RepoError: Cache-only enabled but no cache for 'fedora'
[abrt] python-dnf: repo.py:793:load:RepoError: Cache-only enabled but no cach...
Status: CLOSED DUPLICATE of bug 1225225
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:a3daa9758239f4ef845481d3956...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 11:34 EDT by jniederm
Modified: 2015-08-19 07:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 07:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.02 KB, text/plain)
2015-08-11 11:34 EDT, jniederm
no flags Details
File: environ (3.16 KB, text/plain)
2015-08-11 11:34 EDT, jniederm
no flags Details

  None (edit)
Description jniederm 2015-08-11 11:34:51 EDT
Description of problem:
trying to tab-complete dnf command while being offline (misconfigured routing)

Version-Release number of selected component:
python-dnf-1.0.2-3.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        python2 /usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py list list insta -d 0 -q -C
executable:     /usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py
kernel:         4.1.3-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
repo.py:793:load:RepoError: Cache-only enabled but no cache for 'fedora'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py", line 191, in <module>
    main(sys.argv[1:])
  File "/usr/lib/python2.7/site-packages/dnf/cli/completion_helper.py", line 187, in main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1075, in run
    self._process_demands()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 797, in _process_demands
    load_available_repos=lar)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 243, in fill_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 103, in _add_repo_to_sack
    repo.load()
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 793, in load
    raise dnf.exceptions.RepoError(msg)
RepoError: Cache-only enabled but no cache for 'fedora'

Local variables in innermost frame:
msg: u"Cache-only enabled but no cache for 'fedora'"
self: <Repo fedora>
Comment 1 jniederm 2015-08-11 11:34:54 EDT
Created attachment 1061568 [details]
File: backtrace
Comment 2 jniederm 2015-08-11 11:34:55 EDT
Created attachment 1061569 [details]
File: environ
Comment 3 Honza Silhan 2015-08-19 07:09:55 EDT

*** This bug has been marked as a duplicate of bug 1225225 ***

Note You need to log in before you can comment on or make changes to this bug.