Bug 1252551 - [Docs] Dashboard shows "A plugin is needed to display this content" when viewing in firefox [NEEDINFO]
[Docs] Dashboard shows "A plugin is needed to display this content" when view...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: doc-Technical_Notes (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Julie
Thom Carlin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 12:27 EDT by Thom Carlin
Modified: 2016-10-17 03:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Connecting to the Red Hat CloudForms Portal using the Firefox browser on the QuickStart Cloud Installer machine fails if the Adobe Flash plug-in is not installed. See https://access.redhat.com/solutions/20920 for more information on installing the Adobe Flash plug-in.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-01 19:39:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dajohnso: needinfo? (jhardy)


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-08-11 12:27:31 EDT
Description of problem:

CloudForms web UI shows "A plugin is needed to display this content" when running firefox on Sat6 server connecting to CloudForms.

Version-Release number of selected component (if applicable):

This install was completed from an ISO with the Media ID 1439243191.463927 at 09:46:31 PM on 10 Aug 2015.

How reproducible:

100%

Steps to Reproduce:
1. Install CloudForms using RHCI
2. On Sat6 server, run firefox with url of cloudforms_fqdn
3. Examine Dashboard (default page)
4. Wait for data to start populating

Actual results:

"A plugin is needed to display this content"

Expected results:

All data visible

Additional info:

Think this is the flash plugin.  Alternative is to proxy the connection to CloudForms
Comment 1 Thom Carlin 2015-08-11 13:44:15 EDT
If connection is proxied, a method to proxy between IPv4 and IPv6 would help in environments that require IPv6 for internal or external networks.
Comment 2 John Matthews 2015-08-12 11:08:53 EDT
Thoughts are we'd need to bundle the flash plugin and install so browser can support this.
Comment 3 Jason Montleon 2015-11-25 09:01:22 EST
Looks like it requires flash. Looking at brew I don't see any flash-plugin packages for el7. Do we still have flash-plugin packages in EL7? If not we can't really fix this.
Comment 5 Thom Carlin 2015-11-25 10:04:07 EST
Also please see https://access.redhat.com/discussions/917123
Comment 8 Jason Montleon 2015-11-25 10:15:29 EST
This may be worth a KCS article in case anyone tries to use the Satellite servers browser to access the CloudForms dashboard.
Comment 9 Dave Johnson 2015-11-25 10:32:47 EST
John, what is the CF plan for moving off of flash based charting?  Ideally we would want our products to work with linux based browsers and with flash already dead for the most part, RHCS team would be interested in hearing how/when CF plans to address this.
Comment 10 John Matthews 2015-12-18 13:24:40 EST
Plan is to handle this in documentation only.


Added note to doc text to refer to below kbase article on installing flash.

https://access.redhat.com/solutions/20920
Comment 13 Greg Procunier 2016-10-17 03:54:48 EDT
Considering Google and Mozilla's war on Adobe Flash, what is the plan for Cloud Forms and the Flash plugin?  are you folks going to move to HTML5 at some point so we don't need to keep using this?

Note You need to log in before you can comment on or make changes to this bug.