Bug 1252596 - AttributeError: 'NoneType' object has no attribute 'type'
AttributeError: 'NoneType' object has no attribute 'type'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
abrt_hash:a4fd90604e8322e6b142e643006...
:
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-08-11 16:40 EDT by Mark Harfouche
Modified: 2016-02-29 07:13 EST (History)
17 users (show)

See Also:
Fixed In Version: anaconda-23.19.6-1 anaconda-23.19.6-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 02:27:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jarlgjessing: needinfo-


Attachments (Terms of Use)
File: anaconda-tb (1.12 MB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: anaconda.log (61.61 KB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: environ (663 bytes, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: journalctl (602.50 KB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: lsblk_output (3.04 KB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: nmcli_dev_list (2.77 KB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: os_info (518 bytes, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: program.log (79.93 KB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: storage.log (375.31 KB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details
File: ifcfg.log (6.89 KB, text/plain)
2015-08-11 16:40 EDT, Mark Harfouche
no flags Details

  None (edit)
Description Mark Harfouche 2015-08-11 16:40:37 EDT
Description of problem:
Installing Fedora 23 alpha on my computer.

Version-Release number of selected component:
anaconda-core-23.17-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 175, in doIt
    if boot.type == "mdarray":
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1062, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 196, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'type'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_A-2 ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-blivet-1.10-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Mark Harfouche 2015-08-11 16:40:39 EDT
Created attachment 1061710 [details]
File: anaconda-tb
Comment 2 Mark Harfouche 2015-08-11 16:40:40 EDT
Created attachment 1061711 [details]
File: anaconda.log
Comment 3 Mark Harfouche 2015-08-11 16:40:40 EDT
Created attachment 1061712 [details]
File: environ
Comment 4 Mark Harfouche 2015-08-11 16:40:41 EDT
Created attachment 1061713 [details]
File: journalctl
Comment 5 Mark Harfouche 2015-08-11 16:40:42 EDT
Created attachment 1061714 [details]
File: lsblk_output
Comment 6 Mark Harfouche 2015-08-11 16:40:42 EDT
Created attachment 1061715 [details]
File: nmcli_dev_list
Comment 7 Mark Harfouche 2015-08-11 16:40:43 EDT
Created attachment 1061716 [details]
File: os_info
Comment 8 Mark Harfouche 2015-08-11 16:40:43 EDT
Created attachment 1061717 [details]
File: program.log
Comment 9 Mark Harfouche 2015-08-11 16:40:44 EDT
Created attachment 1061718 [details]
File: storage.log
Comment 10 Mark Harfouche 2015-08-11 16:40:44 EDT
Created attachment 1061719 [details]
File: ifcfg.log
Comment 11 David Shea 2015-08-17 15:09:48 EDT
What did you do leading up to this crash? Did you run anaconda or liveinst more than once?
Comment 12 Mark Harfouche 2015-08-17 17:45:55 EDT
I believe I tried the following:
1. Formatted my new disk (my ram was going bad so I think I had many corrupted files in there).

2. Manually assigned disk partitions (I mostly delete the automatic swap partition that was made on the tiny SSD i have on my laptop).

3. Tried to install Fedora 23 with the live CD.
Comment 13 David Lehman 2015-08-17 19:14:46 EDT
I'm wondering how you got past this:

13:36:35,225 ERR anaconda: storage configuration failed: failed to find a suitable stage1 device
13:36:35,229 ERR anaconda: No valid boot loader target device found. See below for details.
13:36:35,229 ERR anaconda: For a UEFI installation, you must include an EFI System Partition on a GPT-formatted disk, mounted at /boot/efi.

You are not going to have a successful installation without a /boot/efi filesystem so long as you are booting using the EFI firmware. It is absolutely required.

Something seems to have changed in the GUI logic to allow the installation to proceed in spite of storage sanity-check failures.
Comment 14 Mark Harfouche 2015-08-18 12:33:10 EDT
Yea that is weird. It was my first time booting from EFI. I think my BIOS may have been reset to allow it again. I might have been confused as to why I had a /boot and a /boot/efi partition and deleted it the first time around. When I understood the warning message, I think I went back to add it again.

For the record, popping in a F22 (web install I believe) USB seems to have done the trick. No error in Anaconda.

It properly recommended and installed me a EFI partition.
Comment 15 Herbert Carl Meyer 2015-08-27 16:53:40 EDT
Another user experienced a similar problem:

Attempt to install using fedora 23 64 bit net installer alpha. Box is Aspire V5, 4 core AMD processor, 4 gB ram. Standard partitioning selected, fedora worstation + development packages selected.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-WS-23_A-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
package:        anaconda-23.17-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'type'
release:        Cannot get release name.
version:        23
Comment 16 Herbert Carl Meyer 2015-08-27 17:34:01 EDT
Another user experienced a similar problem:

Attempt to install Fedora 23 workstation liveCD from Aug. 25 build on Koji. Box is Acer aspire V5, amd 4 core, with radeon garphics. Similar results to Fedora 23 net install alpha. Back to Fedora 22 ?

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23-2015082 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.10-1.fc23.noarch
package:        anaconda-core-23.17-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'type'
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 17 Herbert Carl Meyer 2015-08-29 08:28:46 EDT
hcmeyer speaking:

The target in my attempted install was an Acer Aspire V5, for cheap from Acer Outlet. Box has a 4 core Amd. I like Amd processors.

After failures of F23 install, I tried an F22 install. The F22 install did insist on a /boot/efi partition, the F23 did not (see comment 14, Marc). However, the F22 install failed, with the message "failed to set new efi boot target. This is most likely a kernel or firmware bug".

I have the latest available firmware in the box, dated 7/24/2014. I think fedora and the EFI firmware do not work together.

I attempted a bare metal restore to the Win8 configuration, using Acer tools. It failed, producing a non-booting system, with a 450 gb win8 partition.

Since I hate windows, and projectile vomit when forced to use it, I reset the BIOS for legacy install, removed the windows partition, and retried F23 net install. It worked, insisting I provide a biosboot partition. That part of the GUI logic seems to work.
Comment 18 Dale Turner 2015-09-12 19:08:46 EDT
Another user experienced a similar problem:

Trying to install F23

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23-2015091 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-blivet-1.12.3-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.3-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'type'
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 19 Chris Murphy 2015-09-27 22:41:41 EDT
I hit this on a Mac 100% of the time if I accidentally try to reuse the real EFI System partition instead of the faux HFS+ one we use on Fedora (neither of which is easy to find or distinguish between BTW).

Because the installer crashes, it seems like this should be a beta blocker bug, but it was never nominated.
Comment 20 Fedora Blocker Bugs Application 2015-09-27 22:43:47 EDT
Proposed as a Blocker for 23-final by Fedora user chrismurphy using the blocker tracking app because:

 Beta criterion:
When using the custom partitioning flow, the installer must be able to: Reject or disallow invalid disk and volume configurations without crashing.
Comment 21 Adam Williamson 2015-09-28 18:08:36 EDT
Discussed at 2015-09-28 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-28/f23-blocker-review.2015-09-28-16.01.html . Accepted as a blocker per criterion cited in #c20. Note, we are not 100% sure of the circumstances that trigger this bug, but it does seem to be a violation of either that criterion, the Windows dual boot criterion, or possibly both. I will try to investigate further this afternoon.
Comment 22 Adam Williamson 2015-09-28 19:09:05 EDT
OK, so my evaluation with F23 Beta: correctly re-using an existing ESP does not seem to cause any crash. Creating a custom layout with no /boot/efi generates a warning message but allows you to proceed by clicking Done twice, after which running the install causes the crash.
Comment 23 Chris Murphy 2015-09-28 19:15:28 EDT
OK and on the Mac I did set a /boot/efi but to to the existing HFS+ ESP, rather the real/original FAT 32 ESP. Maybe that generated an error also and I double doned it.
Comment 24 Vojtech Trefny 2015-09-29 09:52:25 EDT
Pull request: https://github.com/rhinstaller/anaconda/pull/376

updates.img for F23 Beta: https://vtrefny.fedorapeople.org/img/fix1252596.img
Comment 25 Adam Williamson 2015-09-30 17:35:16 EDT
The proposed fix does seem to work correctly. You can leave the spoke without a /boot/efi , but you cannot start the install, it's shown as a blocking error on the hub. If you go back in and add a /boot/efi the error is cleared and install works.
Comment 26 Jarl E. Gjessing 2015-10-02 08:09:11 EDT
Another user experienced a similar problem:

I started installation and when it tried to partition my disk this happened.
I can instal opensuse just fine.
It says Creating ext4 on /dev/sda7

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_B-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-blivet-1.12.4-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.4-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'type'
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 27 Brian Lane 2015-10-02 19:50:59 EDT
(In reply to Jarl E. Gjessing from comment #26)
> Another user experienced a similar problem:
> 
> I started installation and when it tried to partition my disk this happened.
> I can instal opensuse just fine.
> It says Creating ext4 on /dev/sda7

Please attach your /tmp/anaconda-tb-* file
Comment 28 madman37562 2015-10-05 01:58:05 EDT
Another user experienced a similar problem:

Installer froze when attempting to set root password during installation on Late 2011 Late MBP 13"

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Cinnamon-x86_64-23_B ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.12.4-1.fc23.noarch
package:        anaconda-core-23.19.4-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'type'
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 29 Fedora Update System 2015-10-08 14:22:52 EDT
python-blivet-1.12.6-1.fc23 anaconda-23.19.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 30 Fedora Update System 2015-10-09 09:55:08 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update anaconda python-blivet'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6f7d535c92
Comment 31 Fedora Update System 2015-10-12 02:27:14 EDT
anaconda-23.19.6-1.fc23, python-blivet-1.12.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 32 Olli Salonen 2015-10-23 13:30:30 EDT
Another user experienced a similar problem:

I have Macbook Air and I have first installed OS X that creates an EFI partition. I chose to use the existing EFI system partition and mount it as /boot/efi. The installer complained that I had not chosen EFI partition to be mounted as /boot/efi even if I really had done that. I clicked Done to continue anyway. In the next step the installer crashed. This is reproducible in this system.

Partition table below.

Disk /dev/sda: 113 GiB, 121332826112 bytes, 236978176 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 00001CB2-6376-0000-313E-00005E720000

Device         Start       End   Sectors   Size Type
/dev/sda1         40    409639    409600   200M EFI System
/dev/sda2     409640 175230807 174821168  83.4G Apple Core storage
/dev/sda3  175230808 176500343   1269536 619.9M Apple boot
/dev/sda4  176500736 236965887  60465152  28.9G Linux LVM


cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_B-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-blivet-1.12.4-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.4-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'type'
release:        Fedora release 23 (Twenty Three)
version:        23
Comment 33 tschnibo 2015-10-26 02:47:22 EDT
Another user experienced a similar problem:

Tried to install Fedora 23 Beta alongside Windows 10. Formated 80 gb extra Partition in Windows 10 (NTFS). In Fedora installation I selected this partition to delete again. The rest of the Procedure was according to http://www.tecmint.com/install-fedora-21-dual-boot-with-windows-8/ Tried several times with changed settings. After a few seconds of installation progress it generated alway the same error.

cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-WS-x86_64-23_B-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         4.2.0-300.fc23.x86_64
other involved packages: python3-blivet-1.12.4-1.fc23.noarch, python3-libs-3.4.3-5.fc23.x86_64
package:        anaconda-core-23.19.4-1.fc23.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'type'
release:        Fedora release 23 (Twenty Three)
version:        23

Note You need to log in before you can comment on or make changes to this bug.