Bug 1252630 - [packaging] gnome-session-wayland-session and gnome-session-xsession should depend on gnome-shell
[packaging] gnome-session-wayland-session and gnome-session-xsession should d...
Status: ASSIGNED
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
28
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-08-11 19:29 EDT by Christian Stadelmann
Modified: 2018-05-21 16:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch fixing both bugs. (1.49 KB, patch)
2017-09-04 14:46 EDT, Christian Stadelmann
no flags Details | Diff

  None (edit)
Description Christian Stadelmann 2015-08-11 19:29:42 EDT
Description of problem:
gnome-session-wayland-session doesn't depend on gnome-shell

Version-Release number of selected component (if applicable):
Fedora 23 alpha iso

Steps to Reproduce:
0. boot fresh fedora 23 alpha installation
1. open root console
2. type `dnf remove gnome-session-xsession` with gnome-session-wayland-session enabled

Actual results:
dnf tries to remove gnome-shell, gdm and some other packages

Expected results:
gnome-session-wayland-session should be a fully functional replacement for gnome-session-xsession with all dependencies provided.
Comment 1 Matthias Clasen 2016-08-31 18:18:24 EDT
The situation is entirely symmetric. gnome-session-xsession has the same dependencies as gnome-session-wayland-session.
Comment 2 Christian Stadelmann 2016-09-26 14:34:27 EDT
(In reply to Matthias Clasen from comment #1)
> The situation is entirely symmetric. gnome-session-xsession has the same
> dependencies as gnome-session-wayland-session.

You're right. Is this an issue in dnf? or do both gnome-session-xsession and gnome-session-wayland-session have broken dependencies?
Comment 3 Ray Strode [halfline] 2017-08-29 07:12:14 EDT
The gnome-shell Requires might upset people doing weird things like openbox+gnome-session.  I wonder if we should break out /usr/share/gnome-session/sessions/ files into there own subpackages, and then make Requires: gnome-shell go on the subpackages that list org.gnome.Shell as a required component.
Comment 4 Christian Stadelmann 2017-08-29 14:22:09 EDT
(In reply to Ray Strode [halfline] from comment #3)
> The gnome-shell Requires might upset people doing weird things like
> openbox+gnome-session.  I wonder if we should break out
> /usr/share/gnome-session/sessions/ files into there own subpackages, and
> then make Requires: gnome-shell go on the subpackages that list
> org.gnome.Shell as a required component.

Oh, I totally forgot that you can install gnome-session without installing any of its subpackages. Will make a new pull request.
Comment 5 Christian Stadelmann 2017-09-04 14:46 EDT
Created attachment 1321931 [details]
A patch fixing both bugs.

As I was unable to push any commit to pagure (seems broken, I cannot upload my SSH key and cannot see a way to do this without an SSH key), I'll attach a patch here.
Comment 6 Fedora End Of Life 2017-11-16 13:51:00 EST
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 7 Christian Stadelmann 2018-05-21 16:45:33 EDT
Fix: https://src.fedoraproject.org/rpms/gnome-session/pull-request/2

Note You need to log in before you can comment on or make changes to this bug.