Bug 1252646 - [Fuse deployment] Duplicated MVEL version
[Fuse deployment] Duplicated MVEL version
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mario Fusco
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 20:30 EDT by William Antônio
Modified: 2015-10-05 10:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 10:20:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Antônio 2015-08-11 20:30:20 EDT
Description of problem:
After installing BRMS on FUSE using the latest patched version available for 6.1, we can see that two MVEL can be found in the repositories:

list -l -t 0 | grep mvel2
[  66] [Active     ] [            ] [       ] [   80] mvn:org.mvel/mvel2/2.2.1.Final
[ 271] [Active     ] [            ] [       ] [   80] mvn:org.mvel/mvel2/2.2.4.Final-redhat-1


It is a problem because the version 2.2.4 has a few additions and when running the quickstart spring-camel-drools-decision-table-example we have the following error:

Caused by: java.lang.NoSuchMethodError: org.mvel2.ParserContext.<init>(Lorg/mvel2/ParserConfiguration;Ljava/lang/Object;)V

(...)

Can we have a single MVEL version in for camel-mvel and BRMS libraries?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

1) Install BRMS pack on FUSE
2) run "list -l -t 0 | grep mvel2" in fuse console


Actual results:

It returns two different MVEL versions 2.2.1 and 2.2.4 and we have errors running some drools applications becasue it sometimes picks the wrong MVEL

Expected results:

IT should have a single MVEL version installed and no errors when running applications.

Additional info:

The workaround is to remove MVEL 2.2.1.
Comment 7 William Antônio 2015-10-05 10:20:02 EDT
Customer carefully reviewed the installation steps and it works for him. Closing this.

Note You need to log in before you can comment on or make changes to this bug.