Bug 1252665 - dnf not transposing $releasever
dnf not transposing $releasever
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 23:41 EDT by Abel Lopez
Modified: 2015-10-19 12:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 12:07:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abel Lopez 2015-08-11 23:41:24 EDT
Description of problem:
dnf unable to install packages, makecache fails, repolist fails with this error:
dnf makecache
Librepo version: 1.7.16 with CURL_GLOBAL_ACK_EINTR support (libcurl/7.40.0 NSS/3.19.1 Basic ECC zlib/1.2.8 libidn/1.31 libssh2/1.5.0)
lr_download: Target: file:///etc/dnf/dnf.conf (-)
select_next_target: Selecting mirror for: file:///etc/dnf/dnf.conf
prepare_next_transfer: URL: file:///etc/dnf/dnf.conf
add_librepo_xattr: Cannot set xattr user.Librepo.DownloadInProgress (fd: 4): Operation not supported
lr_download: Downloading started
check_transfer_statuses: Transfer finished: file:///etc/dnf/dnf.conf (Effective url: file:///etc/dnf/dnf.conf)
Error: Failed to synchronize cache for repo 'fedora' from 'https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=x86_64': Cannot prepare internal mirrorlist: file "repomd.xml" was not found in metalink

Editing /etc/yum.repos.d/fedora*.repo, replacing all instances of "$releasever" with "22" fixes the problem

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Fresh install of Fedora 22
2. Attempt to install packages
3.

Actual results:
Error: Failed to synchronize cache for repo 'fedora' from 'https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=x86_64': Cannot prepare internal mirrorlist: file "repomd.xml" was not found in metalink


Expected results:
$releasever should be understood by dnf as it worked in yum

Additional info:
I was able to install 1 package successfully, and it seems that perhaps a dependency update caused the problem. It worked immediately after the install.
Comment 1 Radek Holy 2015-08-12 07:03:14 EDT
Interesting. I cannot reproduce it.

Can you please attach /var/log/dnf.log and post the output of "rpm -q --provides fedora-release" and "rpm -q --whatprovides system-release"?

Note You need to log in before you can comment on or make changes to this bug.