Bug 1252670 - RHEV-M Virtual Appliance 'Set root password' does not ask for password confirmation/ 'Run Tool' doesn't work
RHEV-M Virtual Appliance 'Set root password' does not ask for password confir...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance (Show other bugs)
3.5.3
Unspecified Unspecified
medium Severity medium
: ovirt-3.5.8
: 3.5.8
Assigned To: Anatoly Litovsky
Gonza
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 00:19 EDT by Julie
Modified: 2016-02-23 10:38 EST (History)
9 users (show)

See Also:
Fixed In Version: rhevm-appliance-20160128.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 10:38:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhevm_appliance_bug (12.16 KB, image/png)
2015-08-12 00:19 EDT, Julie
no flags Details

  None (edit)
Description Julie 2015-08-12 00:19:17 EDT
Created attachment 1061788 [details]
rhevm_appliance_bug

RHEV-M Virtual Appliance version:
rhevm-appliance-20150727.0-1.x86_64.rhevm.ova

Tested on RHEV-H with self-hosted engine:
rhev-hypervisor6-6.7-20150728.0.el6ev
rhev-hypervisor7-7.1-20150805.0.el6ev

When using the appliance setup utility to configure the Engine VM, the Set root password prompt does not display properly; portions of the field border is missing. See attached screeshot. In addition, it doesn't prompt for re-typing the password for password confirmation.  
After pressing OK and clicking Run Tool, it brings you back to the set root password prompt again. Had to click Quit to exit the utility and check if the password is set or not. This can be quite confusing for end-users. 

I think the utility should only allow users to set root password via 'Set root password' and not 'Run Tool' as well. The utility should prompt for password confirmation. By clicking 'Run Tool', any configuration changes should then be executed and users should be notified that the changes have been successfully made and that they can now exit the utility.
Comment 1 Anatoly Litovsky 2015-08-21 13:14:48 EDT
as far as i understand thats a standard utility for first boot password setting
We can create our own , but I suspect that can confuse all users that used to the current one.
And considering we switch to cloud-init in 3.6 do we want to make any changes to this dialog and confuse all even more.
Comment 2 Julie 2015-08-23 20:07:49 EDT
(In reply to Anatoly Litovsky from comment #1)
> as far as i understand thats a standard utility for first boot password
> setting
> We can create our own , but I suspect that can confuse all users that used
> to the current one.
> And considering we switch to cloud-init in 3.6 do we want to make any
> changes to this dialog and confuse all even more.

hi Anatoly, 
   I think it is the product team's call for this. I'm just reporting this as a usability issue. Personally, I think if a standard utility doesn't prompt for password confirmation and never lets you know that you've set the password and can exit to proceed with the setup, there's something wrong with that utility. 

On another note, is there a docs bug opened to cover the switch to cloud-init in 3.6. I would like to know more how it works in 3.6.

Kind regards,
Julie
Comment 3 Julie 2015-09-16 01:53:13 EDT
To answer my question for cloud-init in 3.6, I have worked with Simone and documented the change for 3.6 and that bit is tracked in BZ#1255231.

Cheers,
Julie
Comment 9 Fabian Deutsch 2016-01-07 10:09:54 EST
This can be tested by:

1. Boot the appliance
2. Select "set root password"
3. Enter a password and submit

After 3 a new dialog comes up and asks to confirm the password
Comment 10 Gonza 2016-01-07 11:16:24 EST
Verified with:
rhevm-appliance-20160106.1-1

No confirmation for password is asked.
Comment 13 Gonza 2016-02-09 03:05:21 EST
Verified with:
rhevm-appliance-20160128.1-1.x86_64.rhevm.ova

Password confirmation required.
Comment 15 errata-xmlrpc 2016-02-23 10:38:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0290.html

Note You need to log in before you can comment on or make changes to this bug.