Bug 1252677 - guests starting in virt-manager with larger screen size than previously
guests starting in virt-manager with larger screen size than previously
Status: CLOSED DUPLICATE of bug 1240721
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
22
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 01:11 EDT by Jens Petersen
Modified: 2015-09-12 11:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-12 11:56:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2015-08-12 01:11:45 EDT
Description of problem:
After some recent update (less than a month ago perhaps)
graphical hosts booted from virt-manager now boot
to a much larger screen size than previously.
This is quite annoying since one basically need to
scale the guest windows so that they fit on monitor.

Version-Release number of selected component (if applicable):
virt-manager-1.2.1-1.fc22

How reproducible:
100%

Steps to Reproduce:
1. boot guest in Virt Manager on F22 (or F23)

Actual results:
After booting the guest screen is as big or bigger than host display.


Expected results:
Smaller screen sizes for guests like before.

Additional info:
I didn't try reverting to a previous version.
Comment 1 Cole Robinson 2015-08-12 10:14:29 EDT
This might be something along the lines of: https://bugzilla.redhat.com/show_bug.cgi?id=1240820

But you say you've seen this on f22 as well, are you using the fedora-virt-preview repo? What libvirt version do you have?

Is this for new VMs only, or even pre-existing ones?
Comment 2 Parag Nemade 2015-08-12 10:22:51 EDT
I too saw this on Fedora 22 few days ago but as fedora 23 got frozen I stopped using virt-manager for sometime and now fresh installed f23 as host system last week. I today tried to install F23 Alpha using virt-manager, first time on this fresh system. The moment I got anaconda installation screen it showed bigger screen( unable to fit on all contents on same screen).

I tried different options in View menu. Finally got full contents when enabled just checkbox View->Scale Display-> "Auto resize VM with windows" and View->Scale Display-> Always.

This was not the case in Fedora 22 host. So, I can reproduce above for f23 on f23 for new VM's.

$ rpm -qa | grep virt | sort
libgovirt-0.3.3-2.fc23.x86_64
libvirt-client-1.2.18-1.fc23.x86_64
libvirt-daemon-1.2.18-1.fc23.x86_64
libvirt-daemon-config-network-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-interface-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-network-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-nodedev-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-nwfilter-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-qemu-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-secret-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-storage-1.2.18-1.fc23.x86_64
libvirt-daemon-kvm-1.2.18-1.fc23.x86_64
libvirt-gconfig-0.2.1-1.fc23.x86_64
libvirt-glib-0.2.1-1.fc23.x86_64
libvirt-gobject-0.2.1-1.fc23.x86_64
libvirt-python-1.2.18-1.fc23.x86_64
redland-virtuoso-1.0.17-4.fc23.x86_64
virt-manager-1.2.1-2.fc23.noarch
virt-manager-common-1.2.1-2.fc23.noarch
Comment 3 Raphael Groner 2015-08-28 09:07:19 EDT
Especially Gtk2 based guests seem to suffer from this restriction in somewhere the complex SPICE logic.
Comment 4 Parag Nemade 2015-09-01 00:09:05 EDT
Easily reproduced today also.
Host is using
parag@f23 ~]$ rpm -qa | grep virt | sort
libgovirt-0.3.3-2.fc23.x86_64
libvirt-client-1.2.18-1.fc23.x86_64
libvirt-daemon-1.2.18-1.fc23.x86_64
libvirt-daemon-config-network-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-interface-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-network-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-nodedev-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-nwfilter-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-qemu-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-secret-1.2.18-1.fc23.x86_64
libvirt-daemon-driver-storage-1.2.18-1.fc23.x86_64
libvirt-daemon-kvm-1.2.18-1.fc23.x86_64
libvirt-gconfig-0.2.2-1.fc23.x86_64
libvirt-glib-0.2.2-1.fc23.x86_64
libvirt-gobject-0.2.2-1.fc23.x86_64
libvirt-python-1.2.18-1.fc23.x86_64
redland-virtuoso-1.0.17-4.fc23.x86_64
virt-manager-1.2.1-3.fc23.noarch
virt-manager-common-1.2.1-3.fc23.noarch
Comment 5 Parag Nemade 2015-09-07 23:30:41 EDT
This is really causing issues with installation UI and then in installed system the window is way to bigger.
Comment 6 Cole Robinson 2015-09-12 11:56:22 EDT
Poked at this, turns out its a spice-gtk issue with a fix upstream. Duping to that bug, I'll do builds shortly

*** This bug has been marked as a duplicate of bug 1240721 ***

Note You need to log in before you can comment on or make changes to this bug.