Bug 1252695 - posix : pending - porting log messages to a new framework
posix : pending - porting log messages to a new framework
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: hari gowtham
:
Depends On: 1242021
Blocks: 1241957 1258736
  Show dependency treegraph
 
Reported: 2015-08-12 02:12 EDT by hari gowtham
Modified: 2016-06-16 09:30 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1242021
: 1258736 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:30:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2015-08-12 02:12:53 EDT
+++ This bug was initially created as a clone of Bug #1242021 +++

Description of problem:
------------------------
There are occurrences of gf_log and gf_log_callingfn under posix.
These instances should be ported to the corresponding gf_msg functions

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1 ( glusterfs-3.7.1-8el6rhs )

Info
-----
gf_log instances
================
[satheesaran@dhcppc1 posix]$ grep -r 'gf_log ' * -A1
src/posix.c: gf_log (this->name, GF_LOG_ERROR,
src/posix.c- "fsetxattr (fstat) failed on fd=%p: %s",

gf_log_callingfn instances
===========================
[satheesaran@dhcppc1 posix]$ grep -r 'gf_log_callingfn ' * -A1
src/posix-helpers.c: callingfn (this->name, GF_LOG_DEBUG, "failed to get gfid");

src/posix.c: gf_log_callingfn (this->name, GF_LOG_ERROR, "Invalid Args: "
src/posix.c-             "fd: %p inode: %p gfid:%s", fd, inode?inode:0,
Comment 1 Anand Avati 2015-08-12 02:49:32 EDT
REVIEW: http://review.gluster.org/11609 (posix.c posix-helpers.c: porting new log messages) posted (#13) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Anand Avati 2015-08-24 01:59:43 EDT
REVIEW: http://review.gluster.org/11609 (posix.c posix-helpers.c: porting new log messages) posted (#16) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Anand Avati 2015-08-24 06:27:48 EDT
REVIEW: http://review.gluster.org/11609 (posix.c posix-helpers.c: porting new log messages) posted (#17) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Anand Avati 2015-08-25 00:42:50 EDT
REVIEW: http://review.gluster.org/11609 (posix.c posix-helpers.c: porting new log messages) posted (#18) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Anand Avati 2015-08-31 02:00:56 EDT
REVIEW: http://review.gluster.org/11609 (posix.c posix-helpers.c: porting new log messages) posted (#19) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Anand Avati 2015-08-31 06:57:55 EDT
REVIEW: http://review.gluster.org/11609 (posix.c posix-helpers.c: porting new log messages) posted (#20) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 7 Niels de Vos 2016-06-16 09:30:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.