Bug 1252696 - After resetting diagnostics.client-log-level, still Debug messages are logging in scrubber log
After resetting diagnostics.client-log-level, still Debug messages are loggin...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Satish Mohan
bugs@gluster.org
: ZStream
Depends On: 1231150
Blocks: 1216951 1315628
  Show dependency treegraph
 
Reported: 2015-08-12 02:15 EDT by Gaurav Kumar Garg
Modified: 2016-06-16 09:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1231150
: 1315628 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:30:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-12 02:18:36 EDT
REVIEW: http://review.gluster.org/11887 (glusterd/bitrot: DEBUG log should not come after resetting client log level) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Anand Avati 2015-08-12 03:12:40 EDT
REVIEW: http://review.gluster.org/11887 (glusterd: DEBUG log should not come after resetting client log level) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Anand Avati 2015-08-13 00:11:49 EDT
REVIEW: http://review.gluster.org/11887 (glusterd: DEBUG log should not come after resetting client log level) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Anand Avati 2015-09-01 10:33:37 EDT
REVIEW: http://review.gluster.org/11887 (glusterd: DEBUG log should not come after resetting client log level) posted (#4) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 5 Vijay Bellur 2015-12-15 01:40:59 EST
REVIEW: http://review.gluster.org/11887 (glusterd: DEBUG log should not come after resetting client log level) posted (#5) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 6 Vijay Bellur 2015-12-15 07:57:31 EST
COMMIT: http://review.gluster.org/11887 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 6e17fb2097f941798e1d56728fd3d61e525a39a5
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Wed Aug 12 01:09:41 2015 +0530

    glusterd: DEBUG log should not come after resetting client log level
    
    After resetting diagnostics.client-log-level option still DEBUG log is
    logging in scrubber and bitrot log file. After resetting any option
    value of that options goes to default value.
    
    This patch will set the default value of client and brick log level to
    "INFO" log level.
    
    Change-Id: I4cf04754dcf5ddc908dae4d9bdf525cfcd6cc2bd
    BUG: 1252696
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/11887
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 9 Niels de Vos 2016-06-16 09:30:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.