Bug 1252727 - tiering: Tier daemon stopped prior to graph switch.
tiering: Tier daemon stopped prior to graph switch.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.3
All All
high Severity high
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Triaged
Depends On: 1240621 1253549
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-08-12 03:28 EDT by Mohammed Rafi KC
Modified: 2015-10-30 13:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1240621
Environment:
Last Closed: 2015-09-09 05:39:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-08-12 03:28:42 EDT
+++ This bug was initially created as a clone of Bug #1240621 +++

Description of problem:

Tier daemon stopped after a graph switch occurs.


Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%


Steps to Reproduce:
1.create a volume and attach a tier
2.turn off any of the performance translator (for a graph change)
3.gluster v rebalance volname tier status

Actual results:

stopped

Expected results:

should not stop

Additional info:

--- Additional comment from Anand Avati on 2015-07-30 01:56:40 EDT ---

REVIEW: http://review.gluster.org/11565 (rebalance/glusterd: Refactor rebalance volfile) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 1 Anand Avati 2015-08-12 03:32:16 EDT
REVIEW: http://review.gluster.org/11889 (rebalance/glusterd: Refactor rebalance volfile) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Kaushal 2015-09-09 05:39:24 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.