Bug 1252731 - DNF crashes when updating Fedora 22 to Rawhide
DNF crashes when updating Fedora 22 to Rawhide
Status: CLOSED DUPLICATE of bug 1252032
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 03:39 EDT by Marius Vollmer
Modified: 2015-08-12 03:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 03:44:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (2.77 KB, application/x-shellscript)
2015-08-12 03:39 EDT, Marius Vollmer
no flags Details
dnf.log (63.37 KB, text/plain)
2015-08-12 03:41 EDT, Marius Vollmer
no flags Details
dnf.rpm.log (1.97 KB, text/plain)
2015-08-12 03:42 EDT, Marius Vollmer
no flags Details

  None (edit)
Description Marius Vollmer 2015-08-12 03:39:44 EDT
Created attachment 1061828 [details]
Reproducer

When running the attached script as of now, DNF crashes like so:

[  153.993020] firstboot.sh[409]: + dnf -y upgrade
[  232.837579] firstboot.sh[409]: Last metadata expiration check performed 0:00:20 ago on Wed Aug 12 03:26:26 2015.
[  237.533123] firstboot.sh[409]: Dependencies resolved.
[  237.568847] firstboot.sh[409]: Traceback (most recent call last):
[  237.570133] firstboot.sh[409]: File "/usr/bin/dnf", line 35, in <module>
[  237.571053] firstboot.sh[409]: main.user_main(sys.argv[1:], exit_code=True)
[  237.571943] firstboot.sh[409]: File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 193, in user_main
[  237.576142] firstboot.sh[409]: errcode = main(args)
[  237.576929] firstboot.sh[409]: File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
[  237.578025] firstboot.sh[409]: return _main(base, args)
[  237.578794] firstboot.sh[409]: File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 146, in _main
[  237.582947] firstboot.sh[409]: ret = resolving(cli, base)
[  237.583736] firstboot.sh[409]: File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 168, in resolving
[  237.584847] firstboot.sh[409]: base.do_transaction(display=displays)
[  237.588776] firstboot.sh[409]: File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 165, in do_transaction
[  237.590015] firstboot.sh[409]: pkg_str = self.output.list_transaction(trans)
[  237.590905] firstboot.sh[409]: File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1024, in list_transaction
[  237.592104] firstboot.sh[409]: for pkg in self._skipped_broken_deps(skipped_conflicts):
[  237.593068] firstboot.sh[409]: File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 947, in _skipped_broken_deps
[  237.597528] firstboot.sh[409]: goal_diff -= skipped_conflicts
[  237.598655] firstboot.sh[409]: TypeError: unsupported operand type(s) for -=: 'set' and 'map'
Comment 1 Marius Vollmer 2015-08-12 03:41:45 EDT
Created attachment 1061829 [details]
dnf.log
Comment 2 Marius Vollmer 2015-08-12 03:42:08 EDT
Created attachment 1061830 [details]
dnf.rpm.log
Comment 3 Parag Nemade 2015-08-12 03:44:21 EDT

*** This bug has been marked as a duplicate of bug 1252032 ***

Note You need to log in before you can comment on or make changes to this bug.