Bug 1252744 - Error adding new torrent: Could not create download: Info hash already used by another torrent.
Error adding new torrent: Could not create download: Info hash already used b...
Status: CLOSED DUPLICATE of bug 1245426
Product: Fedora
Classification: Fedora
Component: rtorrent (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 04:01 EDT by Paul DeStefano
Modified: 2015-08-12 16:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 16:28:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul DeStefano 2015-08-12 04:01:44 EDT
Description of problem:
I could be misinterpreting this error, but it seems like rtorrent says that two torrents have the same hash, a hash collision, which is exceedingly unlikely.  

Version-Release number of selected component (if applicable):
rtorrent-0.9.4-3.fc22.x86_64

How reproducible:
Always with this one torrent:
http://images.kali.org/kali-linux-light-2.0-amd64.torrent

Steps to Reproduce:
1. Start rtorrent
2. Press ENTER
3. Provide torrent URL

Actual results:
The following error message is shown: Could not create download: Info hash already used by another torrent.

Expected results:
No error

Additional info:
Yes, I actually checked all the info hashes, but I'm embarrassed to admit it.

BTW, CTRL-K used to just stop&close a torrent, but it removed one when I tried.  It would be very very helpful if you could include the man page for rtorrent in the RPM.
Comment 1 Paul DeStefano 2015-08-12 04:03:52 EDT
Hmm, yeah, it's happening for all Kali 2.0 torrents, so maybe these torrents are broken or something.
Comment 2 Paul DeStefano 2015-08-12 04:31:36 EDT
Argh! TMUX broken!  When using recommended TMUX workaround, rtorrent doesn't update TUI properly and I couldn't see the new torrents I added so I was trying to add them again.
Comment 3 Ankur Sinha (FranciscoD) 2015-08-12 07:54:46 EDT
So, can I close the bug then? :)
Comment 4 Paul DeStefano 2015-08-12 16:28:23 EDT
Sure, I'll do it.

*** This bug has been marked as a duplicate of bug 1245426 ***

Note You need to log in before you can comment on or make changes to this bug.