Bug 1252751 - Additional packages for "minimal buildroot" need to be installed to (re-)generate SRPM
Additional packages for "minimal buildroot" need to be installed to (re-)gene...
Status: CLOSED NOTABUG
Product: Copr
Classification: Community
Component: backend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 04:13 EDT by Pavel Raiskup
Modified: 2015-08-12 05:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 05:35:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2015-08-12 04:13:58 EDT
Failed build log:
https://copr-be.cloud.fedoraproject.org/results/praiskup/rpm-config/fedora-23-x86_64/00108212-compat-rpm-config/mockchain.log.gz

Package 'compat-rpm-macros' needs to be installed before the SRPM is
generated, otherwise some SPEC macros are not defined.  Not sure whether the
SRPM shouldn't be generated in mock too.

This used to work (it is kind of usage regression) because (a) srpm was not
generated from dist-git before.
Comment 1 Miroslav Suchý 2015-08-12 05:35:03 EDT
You should use those macros conditionally. E.g.
  %{?scl_prefix}
Otherwise somebody else would not be able to generate that SRPM too.
And then you should include that package with macros in build time of binary RPM. Which is doable in Copr for months.

Note You need to log in before you can comment on or make changes to this bug.