This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1252756 - repository definition nor product branding works with nfsiso
repository definition nor product branding works with nfsiso
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Konecny
Fedora Extras Quality Assurance
CommonBugs AcceptedBlocker
:
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-08-12 04:21 EDT by Kamil Páral
Modified: 2015-10-01 12:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-23.19.5-1 anaconda-23.19.5-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-01 10:42:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OK branding with nfs (206.09 KB, image/png)
2015-08-12 04:22 EDT, Kamil Páral
no flags Details
missing branding with nfsiso (215.99 KB, image/png)
2015-08-12 04:23 EDT, Kamil Páral
no flags Details
journal (169.81 KB, text/plain)
2015-08-12 04:23 EDT, Kamil Páral
no flags Details
anaconda.log (6.74 KB, text/plain)
2015-08-12 04:23 EDT, Kamil Páral
no flags Details
program.log (18.89 KB, text/plain)
2015-08-12 04:23 EDT, Kamil Páral
no flags Details
storage.log (42.07 KB, text/plain)
2015-08-12 04:23 EDT, Kamil Páral
no flags Details
syslog (98.42 KB, text/plain)
2015-08-12 04:23 EDT, Kamil Páral
no flags Details
anaconda hub screen with nfsiso (156.13 KB, image/png)
2015-08-12 04:42 EDT, Kamil Páral
no flags Details
journal (160.67 KB, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details
anaconda.log (23.65 KB, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details
dnf.librepo.log (140.27 KB, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details
dnf.log (2.19 KB, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details
packaging.log (750 bytes, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details
program.log (19.50 KB, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details
storage.log (80.05 KB, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details
syslog (99.12 KB, text/plain)
2015-08-12 04:44 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2015-08-12 04:21:43 EDT
Description of problem:
When I boot F23 Alpha Server from PXE with inst.repo=nfs:.../os/ , everything works correctly, I see "Fedora Server" logo in the left bar on the welcome screen. But if I boot it with inst.repo=nfs:...iso/DVD.iso , anaconda loses all branding - there is no "Fedora Server" logo and the left bar is generic gray.

I verified that both paths (os/ and DVD.iso) contain product.img (I assume it contains the branding) and the files are the same.

It seems that product.img is not loaded when booted over nfsiso?

PXE config with working branding:
LABEL Fedora 23 Alpha RC2 Server x86_64
        KERNEL F23/Alpha_RC2/Server/x86_64/vmlinuz
        INITRD F23/Alpha_RC2/Server/x86_64/initrd.img
        APPEND inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/23_Alpha_RC2/Server/x86_64/os/

PXE config with non-working branding:
LABEL Fedora 23 Alpha RC2 Server x86_64
        KERNEL F23/Alpha_RC2/Server/x86_64/vmlinuz
        INITRD F23/Alpha_RC2/Server/x86_64/initrd.img
        APPEND inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/23_Alpha_RC2/Server/x86_64/iso/Fedora-Server-DVD-x86_64-23_Alpha.iso

I attach logs from the nfsiso run.

Version-Release number of selected component (if applicable):
F23 Alpha Server x86_64
anaconda 23.17-1

How reproducible:
seems always

Steps to Reproduce:
1. boot Server from PXE with nfs:.../DVD.iso
2. see no branding
Comment 1 Kamil Páral 2015-08-12 04:22:51 EDT
Created attachment 1061846 [details]
OK branding with nfs
Comment 2 Kamil Páral 2015-08-12 04:23:02 EDT
Created attachment 1061847 [details]
missing branding with nfsiso
Comment 3 Kamil Páral 2015-08-12 04:23:27 EDT
Created attachment 1061848 [details]
journal
Comment 4 Kamil Páral 2015-08-12 04:23:30 EDT
Created attachment 1061849 [details]
anaconda.log
Comment 5 Kamil Páral 2015-08-12 04:23:32 EDT
Created attachment 1061850 [details]
program.log
Comment 6 Kamil Páral 2015-08-12 04:23:34 EDT
Created attachment 1061851 [details]
storage.log
Comment 7 Kamil Páral 2015-08-12 04:23:36 EDT
Created attachment 1061852 [details]
syslog
Comment 8 Kamil Páral 2015-08-12 04:38:10 EDT
I spoke too soon. Not only that branding doesn't work, but repository definition doesn't work either. It should mount the local repository, but instead it defaults to Closest Mirror. Also, probably due to missing repo+branding, it defaults to Minimal install.

I see this in program.log:

08:26:03,744 INFO program: Running... mount -t nfs -o nolock nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/23_Alpha_RC2/Server/x86_64/iso /run/install/source
08:26:04,301 DEBUG program: Return code: 0

And this in packaging log:

08:26:03,744 INFO packaging: mounting nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/23_Alpha_RC2/Server/x86_64/iso: on /run/install/source
08:26:04,411 ERR packaging: base repo (nfs/file:///run/install/source/Fedora-Server-DVD-x86_64-23_Alpha.iso) not valid -- removing it

So it seems anaconda is mounting iso/ directory as the base dir instead of mounting the DVD.iso file itself.
Comment 9 Kamil Páral 2015-08-12 04:42:16 EDT
Created attachment 1061869 [details]
anaconda hub screen with nfsiso

This is how it looks in the main hub when booting with nfsiso.

Attaching a fresh set of log files, including basic initialization (not just the welcome screen).
Comment 10 Kamil Páral 2015-08-12 04:44:11 EDT
Created attachment 1061871 [details]
journal
Comment 11 Kamil Páral 2015-08-12 04:44:13 EDT
Created attachment 1061872 [details]
anaconda.log
Comment 12 Kamil Páral 2015-08-12 04:44:16 EDT
Created attachment 1061873 [details]
dnf.librepo.log
Comment 13 Kamil Páral 2015-08-12 04:44:17 EDT
Created attachment 1061874 [details]
dnf.log
Comment 14 Kamil Páral 2015-08-12 04:44:19 EDT
Created attachment 1061875 [details]
packaging.log
Comment 15 Kamil Páral 2015-08-12 04:44:21 EDT
Created attachment 1061876 [details]
program.log
Comment 16 Kamil Páral 2015-08-12 04:44:24 EDT
Created attachment 1061877 [details]
storage.log
Comment 17 Kamil Páral 2015-08-12 04:44:26 EDT
Created attachment 1061878 [details]
syslog
Comment 18 Kamil Páral 2015-08-12 04:48:04 EDT
Proposing as a blocker due to:
"The installer must be able to use all supported local and remote package and installer sources. "
https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#package-and-installer-sources

Nfsiso is officially supported, even though the documentation is lacking a bit in details:
https://rhinstaller.github.io/anaconda/boot-options.html#repo-nfsiso
Comment 19 Adam Williamson 2015-08-20 13:13:52 EDT
Discussed at 2015-08-20 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-20/f23-blocker-review.2015-08-20-16.05.log.txt . Accepted as a Final blocker per criterion cited in #c18.
Comment 20 Jiri Konecny 2015-09-18 10:13:41 EDT
PR: https://github.com/rhinstaller/anaconda/pull/365
Comment 21 Fedora Update System 2015-09-24 19:35:52 EDT
python-blivet-1.12.5-1.fc23 anaconda-23.19.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe57978cc8
Comment 22 Fedora Update System 2015-09-25 12:32:00 EDT
anaconda-23.19.5-1.fc23, python-blivet-1.12.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update python-blivet anaconda'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe57978cc8
Comment 23 Adam Williamson 2015-09-30 12:51:40 EDT
Should be fixed in Final TC1, Kamil, can you confirm? Thanks!
Comment 24 Kamil Páral 2015-10-01 10:42:00 EDT
This is fixed in F23 TC1.
Comment 25 Fedora Update System 2015-10-01 12:02:04 EDT
anaconda-23.19.5-1.fc23, python-blivet-1.12.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.