This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1252759 - [virt-v2v] Import a VM using virt-v2v of a VM which is currently in lock status will cause an uninitialzed CDA message [NEEDINFO]
[virt-v2v] Import a VM using virt-v2v of a VM which is currently in lock stat...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Arik
Nisim Simsolo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 04:25 EDT by Maor
Modified: 2016-02-18 06:15 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:15:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: needinfo? (ahadas)
ofrenkel: ovirt‑3.6.z?
ylavi: planning_ack?
ofrenkel: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
screen shot (105.46 KB, image/png)
2015-08-12 04:25 EDT, Maor
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46273 master MERGED core: fix CDA message of import vm using virt-v2v Never
oVirt gerrit 49916 ovirt-engine-3.6 MERGED core: fix CDA message of import vm using virt-v2v Never

  None (edit)
Description Maor 2015-08-12 04:25:17 EDT
Created attachment 1061854 [details]
screen shot

Description of problem:
Import a VM using virt-v2v of a VM which is currently in the process of import (The VM is in lock status) will present a message with uninitialzed keys (attached message)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Import a VM from v2v
2. Once the VM is being imported in lock status, try to import it again
3.

Actual results:
an uninitialized message will be performed

Expected results:


Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:59:37 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:28:55 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-26 23:40:32 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 4 Michal Skrivanek 2015-12-04 08:46:15 EST
Arik, this doesn't seem to be in 3.6
Comment 5 Sandro Bonazzola 2015-12-23 08:42:06 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 6 Nisim Simsolo 2016-02-15 04:20:42 EST
Verified using build:
rhevm-3.6.3.1-0.1.el6
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-13.el7_2.2.x86_64
vdsm-4.17.20-0.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64

Verification scenario:
1. Import VMware VM
2. When import phase changed to "initialize" phase or further, try to import the same VM again.
3. Verify in second import dialog that clone checkbox is checked and grayed out (cannot be changed).
4. Click "OK" and verify that the next "operation canceled" message appears:
"Import VM failed - VM Name already exist in the system. Please rename the VM in the system first"

Note You need to log in before you can comment on or make changes to this bug.