Bug 1252769 - undefined method `base_class' for NilClass:Class [catalog/tree_select] when clicking on service catalog item
undefined method `base_class' for NilClass:Class [catalog/tree_select] when c...
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Drew Bomhof
Dave Johnson
: Reopened
Depends On:
Blocks: 1290110
  Show dependency treegraph
Reported: 2015-08-12 04:45 EDT by Christian Jung
Modified: 2016-01-12 09:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290110 (view as bug list)
Last Closed: 2016-01-12 09:25:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
evm.log (1.17 MB, application/x-bzip)
2015-08-12 04:47 EDT, Christian Jung
no flags Details
production.log (8.46 KB, application/x-bzip)
2015-08-12 04:47 EDT, Christian Jung
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2052683 None None None Never

  None (edit)
Description Christian Jung 2015-08-12 04:45:11 EDT
Description of problem:
When I click on an existing Service Catalog Item, the following error is shown:
undefined method `base_class' for NilClass:Class [catalog/tree_select] 

Version-Release number of selected component (if applicable):

How reproducible:
always for this catalog item

Steps to Reproduce:
1. click on Services, Service Catalogs 
2. click on a service catalo item

Actual results:
see error above

Expected results:
the service catalog dialog should be shown

Additional info:
logs will be attaced asap
Comment 1 Christian Jung 2015-08-12 04:47:31 EDT
Created attachment 1061879 [details]
Comment 2 Christian Jung 2015-08-12 04:47:58 EDT
Created attachment 1061880 [details]
Comment 5 Christian Jung 2015-08-14 09:29:41 EDT
I'm not sure if this is relevant, but here we go:

I have two providers in this appliance. RHEV 3.5 and OpenStack 6. There is a service catalog item to order resources in the RHEV environment.

This one always seems to work just fine.

If I create a service catalog item for OpenStack they work fine for some time too. It looks like the item breaks though, if something in the underlying OpenStack environment changes (like for example the network configuration). Also after some time (I don't really have been able to nail it down, but certainly after 24h) the item seems to be "broken".

So it might be related to changes in OSP which we update during inventory refresh and then break the catalog item.

It's only a theory of mine, but I thought it might help to mention it.

Comment 7 Shveta 2015-08-17 14:00:50 EDT
Hi , 

I tried to recreate the issue at 
you can login as admin/smartvm . Under Service Catalogs , there is an item os_item . The template used to create the item was later deleted and so i see the error while editing that item . 

But not on clicking the item under Service Catalogs accordion.
Please check if this is the same error you were seeing .

Comment 8 Brandon Dunne 2015-08-17 15:14:23 EDT
Shveta, are you able to reproduce this on upstream??

The "undefined method 'base_class' for nil" error should be fixed by commits in https://bugzilla.redhat.com/show_bug.cgi?id=1250087
Comment 9 Shveta 2015-08-19 18:45:23 EDT
Not seeing this on upstream
Comment 10 Brandon Dunne 2015-08-31 12:09:54 EDT

I can not reproduce this problem on upstream, 5.4.z, or on the appliance that you referenced.  Are there better instructions for reproducing it?  Does the catalog item need to be created with specific details?

Comment 11 Brandon Dunne 2015-09-21 14:25:22 EDT
Closing since I can't reproduce the problem.  If there are better instructions to do so, please re-open with those.
Comment 14 Christian Jung 2015-11-24 04:59:32 EST
Can comment #12 be used as a reproducer? 

I'm still trying to reproduce this in an internally accessible lab, but having problems with conflicting requests and availability.
Comment 15 Greg McCullough 2015-11-30 11:39:29 EST
Lucy - This seems similar to the work done in PR https://github.com/ManageIQ/manageiq/pull/2947 to allow catalog items to be modified after the template is deleted or orphaned from the provider.

Here it seems the selected Flavor is being deleted and I am not sure what would cause the blow up there.  Re-adding the flavor would not work because it will be associated with a new ID in the database.
Comment 16 Greg McCullough 2015-12-04 10:29:50 EST
Same basic failure as Bug 1236966

From the attached production.log:

[----] F, [2015-08-12T10:21:07.695808 #2593:12c3ea8] FATAL -- : Error caught: [NoMethodError] undefined method `base_class' for NilClass:Class
/var/www/miq/vmdb/app/models/miq_request_workflow.rb:1004:in `ci_to_hash_struct'
/var/www/miq/vmdb/app/models/miq_request_workflow.rb:999:in `add_target'
/var/www/miq/vmdb/app/models/miq_provision_cloud_workflow.rb:98:in `get_source_and_targets'
/var/www/miq/vmdb/app/models/miq_provision_virt_workflow.rb:639:in `get_source_vm'
/var/www/miq/vmdb/app/models/miq_provision_virt_workflow.rb:251:in `update_field_visibility'
/var/www/miq/vmdb/app/models/miq_provision_cloud_workflow.rb:72:in `update_field_visibility'
/var/www/miq/vmdb/app/models/miq_provision_virt_workflow.rb:40:in `initialize'
/var/www/miq/vmdb/app/controllers/application_controller/miq_request_methods.rb:748:in `new'
/var/www/miq/vmdb/app/controllers/application_controller/miq_request_methods.rb:748:in `prov_set_show_vars'
/var/www/miq/vmdb/app/controllers/catalog_controller.rb:1670:in `get_node_info'
/var/www/miq/vmdb/app/controllers/catalog_controller.rb:1758:in `replace_right_cell'
/var/www/miq/vmdb/app/controllers/catalog_controller.rb:313:in `tree_select'
Comment 17 Christian Jung 2016-01-07 04:16:37 EST
Answered NEEDINFO via direct email
Comment 20 Greg McCullough 2016-01-12 09:25:55 EST
We have been unable to reproduce so I am closing this issue for now.  If the issue appears again please reopen the ticket with steps to reproduce.

Note You need to log in before you can comment on or make changes to this bug.