Bug 1252781 - Slapd crashes reported from latest builds of 389-ds-base-1.3.4.0-10
Summary: Slapd crashes reported from latest builds of 389-ds-base-1.3.4.0-10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 7.2
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-12 08:57 UTC by Sankar Ramalingam
Modified: 2015-11-19 11:44 UTC (History)
4 users (show)

Fixed In Version: 389-ds-base-1.3.4.0-11.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 11:44:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Stacktrace for slapd crash (187.75 KB, text/plain)
2015-08-12 08:58 UTC, Sankar Ramalingam
no flags Details
Valgrind output for Distrib_logic tests (38.20 KB, text/plain)
2015-08-13 14:02 UTC, Sankar Ramalingam
no flags Details
Valgrind output with the scratch build (37.58 KB, text/plain)
2015-08-14 12:20 UTC, Sankar Ramalingam
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2351 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2015-11-19 10:28:44 UTC

Description Sankar Ramalingam 2015-08-12 08:57:06 UTC
Description of problem: Automated acceptance tests execution shows crashes from latest builds of 389-ds-base.

Version-Release number of selected component (if applicable): 389-ds-base-1.3.4.0-10

How reproducible: Consistently for 1.3.4.0-9 and 1.3.4.0-10.


Steps to Reproduce:
1. Run automated acceptance from Jenkins. Build a trigger job for RHEL72.
2. Wait till the acceptance reports are generated. Nearly 10 hrs.
3. Crash reports generated from the acceptance machine.

Actual results: Slapd crashes for replication tests.

Expected results: No crash

Additional info: This looks like its coming from NSS.

Comment 1 Sankar Ramalingam 2015-08-12 08:58:14 UTC
Created attachment 1061885 [details]
Stacktrace for slapd crash

Comment 6 Sankar Ramalingam 2015-08-13 13:53:31 UTC
The crash is coming from Distrib_logic tests. I ran it under valgrind to check what is the output. It will be available soon.

Comment 7 Sankar Ramalingam 2015-08-13 14:02:43 UTC
Created attachment 1062598 [details]
Valgrind output for Distrib_logic tests

Comment 11 Sankar Ramalingam 2015-08-14 12:20:28 UTC
Created attachment 1063002 [details]
Valgrind output with the scratch build

[root@mgmt2 ~]# rpm -qa |grep -i 389-ds-base
389-ds-base-libs-1.3.4.0-10.1.el7.x86_64
389-ds-base-1.3.4.0-10.1.el7.x86_64
389-ds-base-debuginfo-1.3.4.0-10.1.el7.x86_64

Comment 13 Noriko Hosoi 2015-08-14 16:00:21 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/48250

Comment 15 Sankar Ramalingam 2015-08-18 11:59:57 UTC
No crashes observed with the latest build of 389-ds-base.
Acceptance test report - http://wiki.idm.lab.bos.redhat.com/qa/archive/beaker/x86_64/389-ds-base-1.3.4.0-11.el7.x86_64/Linux/20150817-223704.html

Also, no crashes observed with distrib_logic tests run on the same where I reproduced the crash for 389-ds-base-1.3.4.0-10.

Marking the bug as Verified based on the above statements.

Build tested:
[root@mgmt2 ~]# rpm -qa |grep -i 389
389-ds-base-1.3.4.0-11.el7.x86_64
389-ds-base-libs-1.3.4.0-11.el7.x86_64
389-ds-base-debuginfo-1.3.4.0-11.el7.x86_64

Comment 16 errata-xmlrpc 2015-11-19 11:44:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2351.html


Note You need to log in before you can comment on or make changes to this bug.