Bug 1252792 - [abrt] [faf] Crash in ect_dispose() on quit
[abrt] [faf] Crash in ect_dispose() on quit
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution (Show other bugs)
7.2
x86_64 Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Milan Crha
Desktop QE
http://faf-report.itos.redhat.com/rep...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 05:10 EDT by Vadim Rutkovsky
Modified: 2015-11-19 02:59 EST (History)
2 users (show)

See Also:
Fixed In Version: evolution-3.12.11-14.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:59:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 748878 None None None Never

  None (edit)
Description Vadim Rutkovsky 2015-08-12 05:10:39 EDT
Seems to happen randomly on Evolution shutdown

Report URL: http://faf-report.itos.redhat.com/reports/bthash/b3ccf101b24e237cef6715a72e8e8c4277b24aec/
Comment 1 Milan Crha 2015-08-12 09:34:02 EDT
Thanks for a bug report. It looks like upstream bug [1]. The code doesn't match exactly in the 3.12.11 and in the upstream bug, one file was added meanwhile, but the change is otherwise applicable, thus I guess it should fix it. I made a test build at [2], with which you can give it a try before I apply it to package sources.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=748878
[2] https://brewweb.devel.redhat.com/taskinfo?taskID=9679341
Comment 2 Vadim Rutkovsky 2015-08-14 04:45:17 EDT
Verified https://brewweb.devel.redhat.com/taskinfo?taskID=9679345 - no crash occurs after several runs. CI and FAF will make sure the crash didn't occur anymore
Comment 3 Milan Crha 2015-08-14 04:45:36 EDT
I would not include this bug report in the errata doc text, as this is kind of sporadic crash, with no exact steps to reproduce. The upstream bug (comment #1) has some steps, but the code is not the same and I was not able to reproduce it with those steps too.
Comment 5 Vadim Rutkovsky 2015-09-07 07:07:12 EDT
Cannot reproduce in evolution-3.12.11-15.el7.x86_64
Comment 6 Vadim Rutkovsky 2015-10-08 07:22:32 EDT
FAF has registered 6 crashes for evolution-3.12.11-15.el7.x86_64: see affected versions in http://faf-report.itos.redhat.com/reports/7867/

I'll reopen the issue as soon as I'll get more information
Comment 7 errata-xmlrpc 2015-11-19 02:59:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2226.html

Note You need to log in before you can comment on or make changes to this bug.