Bug 1252807 - libgfapi : pending - porting log messages to a new framework
libgfapi : pending - porting log messages to a new framework
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Manikandan
:
Depends On: 1242268 1258406
Blocks: 1241957
  Show dependency treegraph
 
Reported: 2015-08-12 05:27 EDT by Manikandan
Modified: 2016-09-20 00:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1242268
Environment:
Last Closed: 2016-06-16 09:30:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-08-12 05:27:51 EDT
+++ This bug was initially created as a clone of Bug #1242268 +++

Description of problem:
------------------------
There are few gf_log instance under api directory in the source code base of glusterfs. These should be ported to new logging framework

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1 Nightly Build ( glusterfs-3.7.1-8.el6rhs )

Instances of gf_log
-------------------
[satheesaran@dhcppc1 api]$ grep -r "gf_log " * -A1
src/glfs-fops.c:        gf_log (THIS->name, GF_LOG_DEBUG,
src/glfs-fops.c-                "Upcall gfapi callback is called");
--
src/glfs-fops.c:        gf_log (THIS->name, GF_LOG_TRACE, "Upcall gfapi gfid = %s"
src/glfs-fops.c-                "ret = %d", (char *)(upcall_data->gfid), ret);
--
src/glfs-fops.c:                gf_log (THIS->name, GF_LOG_ERROR, "Upcall entry allocation"
src/glfs-fops.c-                        "failed.");
--
src/glfs-handleops.c:                        gf_log (subvol->name, GF_LOG_WARNING,
src/glfs-handleops.c-                                "handle creation of %s failed: %s",
Comment 1 Anand Avati 2015-08-12 08:01:03 EDT
REVIEW: http://review.gluster.org/11891 (libgfapi : port missing gf_log's to gf_msg) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Anand Avati 2015-08-13 07:03:21 EDT
REVIEW: http://review.gluster.org/11891 (libgfapi : port missing gf_log's to gf_msg) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Anand Avati 2015-08-31 05:45:35 EDT
COMMIT: http://review.gluster.org/11891 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 1e0644031c7ac0fa28f0912e951a9238f7bbe8ab
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Wed Aug 12 14:46:29 2015 +0530

    libgfapi : port missing gf_log's to gf_msg
    
    Change-Id: I0c5320c09b4a5ff1e9df61a86ac7bd47c1bb1bbb
    BUG: 1252807
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/11891
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:30:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.