Bug 1252823 - Please include plugin script
Summary: Please include plugin script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: elasticsearch
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1226445 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-12 09:57 UTC by Pavel Alexeev
Modified: 2016-01-19 23:27 UTC (History)
5 users (show)

Fixed In Version: elasticsearch-1.7.1-3.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-19 23:27:55 UTC
Type: Bug


Attachments (Terms of Use)
Fix for 1252823 and 1296308 bugs (7.69 KB, patch)
2016-01-06 21:21 UTC, Pavel Alexeev
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Github elastic elasticsearch issues 11797 None None None Never
Red Hat Bugzilla 1296308 None None None Never

Internal Links: 1296308

Description Pavel Alexeev 2015-08-12 09:57:56 UTC
Hello.

In repack.sh you delete "elasticsearch elasticsearch.bat elasticsearch-service-mgr.exe elasticsearch-service-x64.exe elasticsearch-service-x86.exe plugin plugin.bat service.bat".

I understand what binaries must be stripped. But what with plugin, which is just shell script? I assume it is not sane way install such plugions which is not in rpm form, and it is main reason of excludin, is not? But may we let it on administrator choose when desired plugin is not packaged?

Could you please include that script in package as it done in upstream rpm?

Comment 1 Zbigniew Jędrzejewski-Szmek 2015-08-12 17:20:33 UTC
I see how that could be useful. Jiri, what do you think?

Comment 2 jiri vanek 2015-08-13 06:36:16 UTC
I have nothing against adding shell for adding plugins. but...
Maybe I miss something, but upstream plugin.sh as it is, is unusable. We have to rewrite it from scratch or heavily patch to fit fedora installation. Same as was necessary with upstream launching script:(

Pavel, are you volunteer? I even dont knw how to test whether it works. I'm using elastic for really simple tasks  so I'm happy with current state of things. If people needs more, they have to help. (as eg. zbyszek do)

Upstream rpm have everything in single directory. And all dependences built in. Fedora can't do that and upstream is exactly not cooperative...

Comment 3 Pavel Alexeev 2015-12-08 22:01:39 UTC
Jiri thank you for the answer.

I'm use several plugins for elasticsearch like kopf, gui, Russian morphology, etc. Do we ever have some guidelines how to package such plugins for elastic in rpm?
And that is very useful even for Fedora installation install it as plugins via upstream mechanism. As I understand there only paths adjustment needed. Are you willing I try provide patch for that?

Comment 4 jiri vanek 2015-12-09 07:18:55 UTC
No guidelines at all :)

I can see are 2x2 approaches I would guess. I font know which will be more valid, so yours usecase - first usecase.
(global space plugin x  user's space plugin) x (rpm packed plugin x upstream-like handled plugin)

I guess that global space + upstream-like handled would be most simple, but as I told. Your usecase is the way to go, as whole this thing is goig to evole...now. (and you may be the only user for some time...)

If you will try to provide patch, I will try to include it in RPMS:)

TY!

Comment 5 jiri vanek 2015-12-16 10:23:13 UTC
*** Bug 1226445 has been marked as a duplicate of this bug. ***

Comment 6 Pavel Alexeev 2016-01-06 21:16:21 UTC
Proper solution for that should come from https://github.com/elastic/elasticsearch/issues/11797

Now I could provide simple solution requested initially. Please revisit attached patch. It also fixes bz#1296308 (which is very annoying even for tests).

Comment 7 Pavel Alexeev 2016-01-06 21:21:02 UTC
Created attachment 1112248 [details]
Fix for 1252823 and 1296308 bugs

If you want I could push it myself.

I also request access to package to co-maintain it if you are willing.

Comment 8 jiri vanek 2016-01-07 15:41:28 UTC
Yup sure, I added you to maintainers. Go on and fix what you need. Considering it will be kept working :)

Comment 9 Pavel Alexeev 2016-01-10 19:00:43 UTC
Thank you!
Sure I'll try be careful.

Comment 10 Fedora Update System 2016-01-10 19:54:40 UTC
elasticsearch-1.7.1-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1885bffc8c

Comment 11 Fedora Update System 2016-01-11 13:52:53 UTC
elasticsearch-1.7.1-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1885bffc8c

Comment 12 Fedora Update System 2016-01-19 23:27:48 UTC
elasticsearch-1.7.1-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.