Bug 1252848 - system/kdump: Rewrite to better cover kdump/zipl case
system/kdump: Rewrite to better cover kdump/zipl case
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant-contents (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: pstodulk
Alois Mahdal
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 07:20 EDT by Alois Mahdal
Modified: 2016-04-04 15:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Check when kernel-kdump is installed on the system and in this case requires manual action of user before upgrade - set high risk and print remedy instructions. In addition presence of "kdump" item in zipl.conf file is checked for additional log message.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 04:50:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alois Mahdal 2015-08-12 07:20:52 EDT
Background
==========

On s390x, if user installed kernel-kdump using installer UI (anaconda,
as opposed to installing the package later using eg. yum) but later
removed it using rpm/yum, system could end up with corrupted zipl.conf
(in some cases even unbootable).


Description of problem
======================

Current implementation of system/kernel-kdump content is trying to help
user with above scenario by advicing them but also by attempting to fix
the situation.  This has proved unreliable, too bold and potentially
causing more harm than good.

Replace content with new implementation based only on detecting,
explaining and advising on the problem, and leaving the solution up to
the user.


Version-Release number of selected component
============================================

preupgrade-assistant-contents-0.6.30-1.el6


How reproducible
================

Always


Steps to Reproduce
==================

 1. Run anaconda installer and select kernel-kdump to be installed

 2. On the new system, remove kernel-kdump using yum or similar
    but do not update /etc/zipl.conf

 3. Run preupg

 4. Run redhat-upgrade-tool to upgrade to RHEL7


Actual results
==============

 *  Preupg says (in result.html or similar) it's planning to remove
    kernel-kdump

 *  redhat-upgrade-tool removes kernel-kdump and attempts
    to update zipl.conf


Expected results
================

 *  Preupg raises HIGH risk and explains the situation in result.html.
    Solution is left to user.
Comment 4 Alois Mahdal 2015-08-12 12:57:49 EDT
Verified:

 *  If kdump is installed *and* present in zipl.conf,
    => two separate HIGH risks are issued.

 *  If kdump is installed *but not* present in zipl.conf,
    => one HIGH risk is issued.

 *  If kdump is neither installed *nor* present in zipl.conf,
    => no related HIGH risk is issued.

 *  In any case,
    => no preupgrade-scripts are generated.
Comment 6 errata-xmlrpc 2015-08-13 04:50:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1608.html

Note You need to log in before you can comment on or make changes to this bug.