Bug 1252851 - [CACHE-TIER]: object not evicted from the cache pool based on target_max_object policy
[CACHE-TIER]: object not evicted from the cache pool based on target_max_obje...
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity medium
: rc
: 1.3.2
Assigned To: Loic Dachary
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 07:24 EDT by shylesh
Modified: 2017-07-30 11:13 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHEL: ceph-0.94.5-1.el7cp Ubuntu: ceph_0.94.5-2redhat1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:42:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 12673 None None None Never

  None (edit)
Description shylesh 2015-08-12 07:24:23 EDT
Description of problem:
tiering agent is not evicting the objects based on target_max_objects policy

Version-Release number of selected component (if applicable):
0.94.1.4-1trusty

How reproducible:
always

Steps to Reproduce:
 
 http://tracker.ceph.com/issues/12673#change-56512
 

Actual results:


Expected results:


Additional info:
Comment 2 Kefu Chai 2015-08-13 01:48:59 EDT
see the http://tracker.ceph.com/issues/12673#note-9 , it's expected behaviour.
Comment 3 Kefu Chai 2015-08-13 04:50:04 EDT
i am still on it.
Comment 4 Ken Dreyer (Red Hat) 2015-12-11 16:52:10 EST
https://github.com/ceph/ceph/pull/5765 merged upstream and shipped in upstream's v0.94.4. This will be in RHCS 1.3.2.
Comment 6 shylesh 2016-02-06 12:26:21 EST
Verified on ceph-0.94.5-4.el7cp.x86_64

Now the objects which are promoted and evicted based on target_max_object policy.
Though always cache pool makes sure that number of objects < target_max_object but exact number of target_max_object limit is not satisfied for which I will log a new bug https://bugzilla.redhat.com/show_bug.cgi?id=1305283.
Comment 8 errata-xmlrpc 2016-02-29 09:42:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0313

Note You need to log in before you can comment on or make changes to this bug.