Bug 1252905 - intermittent guest install problem (image mount error) with f23 ppc64 alpha1
Summary: intermittent guest install problem (image mount error) with f23 ppc64 alpha1
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 23
Hardware: ppc64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker F23PPCAlpha
TreeView+ depends on / blocked
 
Reported: 2015-08-12 13:31 UTC by Menanteau Guy
Modified: 2015-08-24 12:26 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-08-23 15:17:21 UTC


Attachments (Terms of Use)
console log (1.86 MB, text/plain)
2015-08-12 13:31 UTC, Menanteau Guy
no flags Details

Description Menanteau Guy 2015-08-12 13:31:17 UTC
Created attachment 1061947 [details]
console log

Trying to install f23 ppc64 alpha1 http://ppc.koji.fedoraproject.org/compose/23_Alpha_RC1/23/Server/ppc64/iso/Fedora-Server-DVD-ppc64-23.iso as cdrom
on a guest in a PKVM host failed with image mount error.

This problem is intermittent and I did not see it on ppc64le guest install.

qemu command:
/usr/bin/qemu-system-ppc64 -name f23_Alpha1_53 -enable-kvm -M pseries -smp 4 -m 6G -nographic -nodefaults -monitor stdio -serial pty -device virtio-net-pci,netdev=net10092,mac=c0:ff:ee:00:00:53 -netdev bridge,br=br0,id=net10092 -cdrom Fedora-Server-DVD-ppc64-23.iso -drive file=hd1.qcow2 -drive file=hd2.qcow2 -boot d -S

console log extract:
[   10.258624] random: nonblocking pool is initialized
[   10.424359] dracut-initqueue[555]: anaconda using disk root at /dev/sr0
[   10.441160] dracut-initqueue[555]: mount: /dev/sr0 is write-protected, mounting read-only
[   10.446709] dracut-initqueue[555]: anaconda: found /run/install/repo//images/install.img
[   10.469821] loop: module loaded
[   10.465425] dracut-initqueue[555]: mount: wrong fs type, bad option, bad superblock on /dev/loop0,
[   10.466225] dracut-initqueue[555]: missing codepage or helper program, or other error
[   10.467742] dracut-initqueue[555]: In some cases useful info is found in syslog - try
[   10.468415] dracut-initqueue[555]: dmesg | tail or so.
[   10.470521] dracut-initqueue[555]: Warning: can't unpack filesystem image!
[   10.472326] dracut-initqueue[555]: /lib/dracut-lib.sh: line 679: cd: /tmp/product.img.684: No such file or directory


Note that dracut exit at the end and I was not able to get any log except the console one.

Comment 1 David Shea 2015-08-12 14:36:58 UTC
[   10.494035] dracut-initqueue[555]: cp: error reading './proc/144/task/144/mem': Input/output error

Looks like either a kernel or a hardware failure, and since the hardware is fake assigning to kernel.

Comment 2 Dan Horák 2015-08-17 13:38:02 UTC
[   10.424359] dracut-initqueue[555]: anaconda using disk root at /dev/sr0
[   10.441160] dracut-initqueue[555]: mount: /dev/sr0 is write-protected, mounting read-only
[   10.446709] dracut-initqueue[555]: anaconda: found /run/install/repo//images/install.img
[   10.469821] loop: module loaded
[   10.465425] dracut-initqueue[555]: mount: wrong fs type, bad option, bad superblock on /dev/loop0,
[   10.466225] dracut-initqueue[555]: missing codepage or helper program, or other error
[   10.467742] dracut-initqueue[555]: In some cases useful info is found in syslog - try
[   10.468415] dracut-initqueue[555]: dmesg | tail or so.
[   10.470521] dracut-initqueue[555]: Warning: can't unpack filesystem image!
[   10.472326] dracut-initqueue[555]: /lib/dracut-lib.sh: line 679: cd: /tmp/product.img.684: No such file or directory
[   10.494035] dracut-initqueue[555]: cp: error reading './proc/144/task/144/mem': Input/output error

Other explanation might be zero length product.img caused by an issue in xz (too many CPUs and not enough memory) when preparing the compose.

Comment 3 Ngo Than 2015-08-18 09:08:27 UTC
i got the same installation issue. After changing the memory from 16384MB to 32000MB it works.

Menanteau Guy, could you please try to change the memory and test again if it works for you?

Comment 4 Jakub Čajka 2015-08-18 11:52:30 UTC
For the record, the same issue also affects bare-metal P8 installation. Seems similar to BZ#1215669 (bug for issue mentioned in comment #2).

Comment 5 Menanteau Guy 2015-08-18 12:07:28 UTC
Ngo Than, not sure of what memory you are talking about.
In "qemu guest create command" indicated in comment 1, you can see that the guest is done with -m 6G . I also tried with 8G memory without better result.
Keep in mind it is a transient problem.

I do agree with comment 2 of Dan and I suggest to wait a better compose with a product.img not empty to see if this problem is still alive.

Comment 6 Menanteau Guy 2015-08-18 12:09:52 UTC
mistake on comment 5, "qemu guest create command" is indicated in "description" not in comment 1.

Comment 7 Ngo Than 2015-08-19 10:01:58 UTC
(In reply to Menanteau Guy from comment #5)
> Ngo Than, not sure of what memory you are talking about.
> In "qemu guest create command" indicated in comment 1, you can see that the
> guest is done with -m 6G . I also tried with 8G memory without better result.
> Keep in mind it is a transient problem.
> 

i created the VM with the kimchi, there's a option memory where the user can change. I changed it to 3200MB and it works for me. Afterthat I tried to create  new VM again with memory 32000MB and it failed this time. It seems this problem is randomly. I have investigated but still haven't found the cause.

> I do agree with comment 2 of Dan and I suggest to wait a better compose with
> a product.img not empty to see if this problem is still alive.

i do agree too.

Comment 8 Dan Horák 2015-08-21 20:23:14 UTC
From my testing it seems that with F23 Alpha RC2 this problem went away, but please recheck too before we will close this bug.

Comment 9 Peter Robinson 2015-08-23 15:17:21 UTC
Fixed in Alpha RC2

Comment 10 Menanteau Guy 2015-08-24 09:20:29 UTC
Problem not reproductible after several tries with Alpha_RC2. http://ppc.koji.fedoraproject.org/compose/23_Alpha_RC2/23/Server/ppc64le/iso/Fedora-Server-DVD-ppc64le-23.iso

Comment 11 Ngo Than 2015-08-24 09:58:47 UTC
i can comfirm that the bug is fixed in alpha rc2.

http://ppc.koji.fedoraproject.org/compose/23_Alpha_RC2/23/Server/ppc64/iso/Fedora-Server-DVD-ppc64-23.iso


Note You need to log in before you can comment on or make changes to this bug.