Bug 1252911 - Icons are missing from the Orchestration Stack Topology in Overcloud Horizon
Icons are missing from the Orchestration Stack Topology in Overcloud Horizon
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity medium
: z2
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 09:42 EDT by Marius Cornea
Modified: 2016-04-26 21:24 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-django-horizon-2015.1.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:22:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
heat icons (124.62 KB, image/png)
2015-08-12 09:42 EDT, Marius Cornea
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2120351 None None None 2016-01-12 03:42 EST
OpenStack gerrit 217951 None None None Never

  None (edit)
Description Marius Cornea 2015-08-12 09:42:25 EDT
Created attachment 1061960 [details]
heat icons

Description of problem:
Overcloud deployment with 1 controller, 1 compute and 1 swift node. After creating a heat stack the icons in the Orhcestration Topology tab don't show up.

404 returned for the following liks:
http://10.3.58.10/static/dashboard/img/unknown-green.svg
http://10.3.58.10/static/dashboard/img/server-green.svg
http://10.3.58.10/static/dashboard/img/stack-green.svg
http://10.3.58.10/project/stacks/get_d3_data/392d8f3a-b8c8-4b43-8c1e-afaf2af2f4f8/ 

Version-Release number of selected component (if applicable):
openstack-dashboard-2015.1.0-10.el7ost.noarch
openstack-dashboard-theme-2015.1.0-10.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud
2. Create a heat stack on overcloud
3. Access overcloud horizon and check the Orhcestration Stacks Topology tab

Actual results:
Icons images are not found on server.

Expected results:
The topology graph loads the icons.

Additional info:
Attaching screenshot.
Comment 4 Matthias Runge 2015-08-31 05:38:35 EDT
As a workaround, adding 
 Alias /static "/usr/share/openstack-dashboard/static"

to dashboard config in /etc/httpd.conf.d/15-horizon_vhost.conf
should work.
Comment 5 Matthias Runge 2015-08-31 08:21:29 EDT
two conflicting patches out there trying to fix this
Comment 9 Matthias Runge 2015-09-07 03:12:09 EDT
How to test:
- install with heat enabled
- (try to) launch a heat stack, view the stack
- previously, icons were completely missing in the overview map
Comment 11 Ido Ovadia 2015-09-20 09:09:54 EDT
Verified
========
python-django-horizon-2015.1.1-2.el7ost.noarch
Comment 13 errata-xmlrpc 2015-10-08 08:22:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1874

Note You need to log in before you can comment on or make changes to this bug.