Bug 1252941 - UCLI endpoint/catalog list is showing PublicURL for all endpoints
UCLI endpoint/catalog list is showing PublicURL for all endpoints
Status: ASSIGNED
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Julie Pichon
Shai Revivo
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 10:43 EDT by jhoffer
Modified: 2017-09-30 22:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jhoffer 2015-08-12 10:43:35 EDT
Description of problem:
openstack UCLI client and (deprecated) keystone client are displaying different information.


Version-Release number of selected component (if applicable):
RHELOSP-7, RHELOSP7-Director
python-openstackclient-1.0.3-2.el7ost.noarch
python-keystoneclient-1.3.0-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. # openstack catalog list
2. # keystone catalog
3. They are not the same, UCLI shows PublicURL for all endpoints, including Admin and Internal

Actual results:
The two commands display different output.  UCLI is showing PublicURL for all endpoints.

Expected results:
They should display the same output.

Additional info:
bnemec has looked at this, it is only a display bug

Note You need to log in before you can comment on or make changes to this bug.